[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MXE-NSIS build

From: John Donoghue
Subject: Re: MXE-NSIS build
Date: Tue, 12 Nov 2013 19:55:31 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.1.0

On 11/12/2013 05:55 PM, Rik wrote:
On 11/12/2013 01:28 PM, John D wrote:

-----Original Message-----
From: Rik [mailto:address@hidden
Sent: Tuesday, November 12, 2013 1:37 PM
To: John D
Cc: address@hidden
Subject: Re: MXE-Octave NSIS build

On 11/12/2013 07:44 AM, address@hidden wrote:
Message: 2
Date: Tue, 12 Nov 2013 01:43:46 -0500
From: John Donoghue <address@hidden>
To: address@hidden
Subject: Re: Octave-maintainers Digest, Vol 92, Issue 46
Message-ID: <address@hidden>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 11/12/2013 01:00 AM, address@hidden wrote:
Message: 3
Date: Mon, 11 Nov 2013 19:46:20 -0800
From: Rik<address@hidden>
To: Octave Maintainers<address@hidden>
Subject: MXE-Octave building (11/11/13)
Message-ID: <address@hidden>
Content-Type: text/plain; charset=UTF-8


I've never tried it, but it seems increasingly necessary to try and
get a MinGW copy of Octave myself so that I can debug things.  I
tried using the instructions
athttp://wiki.octave.org/Windows_Installer.  The instructions call
for using './mk-dist --installer' which fails for me near the
bottom of the script.  Is this supposed to work or is only zip-file
creation supported?
The proximate cause of the failure is this stanza near the bottom
of the mk-dist script.

if [ $installer = "yes" ]; then
    $SHELL ../makeinst-script.sh $OCTAVE_TARGET-$DATE

$SHELL, in my case, is /bin/tcsh which fails to parse
makeinst-script.sh which is a Bourne shell script.  But even when I
replace $SHELL with /bin/sh it still fails further along.

Whats the error?
The error was still caused by an incorrect shell.  It turns out the
makeinst-script.sh is not a Bourne shell, but a bash shell, script.  If I
replace $SHELL with /bin/bash then everything at least runs without error,
although no executable installer is made.  Is it possible to remove the
$SHELL reference and just begin the line with '../makeinst-script.sh' which
will use the UNIX #! mechanism to pick up the right shell?  If not, because
this script may run on non-UNIX platforms, then $SHELL needs to be changed
to guarantee that it points to a bash shell executable.


If you delete the space in the first line of the makeinst-script so it is
#!/bin/bash, does the the shell then load bash on running the script ?


The #! mechanism works with or without a space.  Apparently the repository
for MXE Octave has different permissions than the main one and I am unable
to push changesets back.  You seem to have write permission, could you push
the attached two changesets?

The first uses default -j options for Make and the second one eliminates
the $SHELL usage which then allows the script to run for people using tcsh,
zsh, etc.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]