[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Editor in GUI

From: Doug Stewart
Subject: Re: Editor in GUI
Date: Thu, 14 Nov 2013 15:29:46 -0500

On Thu, Nov 14, 2013 at 3:13 PM, Torsten <address@hidden> wrote:
On 14.11.2013 20:30, Doug Stewart wrote:
> On Thu, Nov 14, 2013 at 1:44 PM, Torsten <address@hidden
> <mailto:address@hidden>> wrote:
>     On 14.11.2013 10:53, Doug Stewart wrote:
>     >     How do you try to open the existing file before the crash,
>     with the
>     >     menus of the GUI or with edit.m?
>     >
>     >
>     >
>     > I use the mouse and click on the button, in the menu bar, that is
>     > supposed to open an existing file.
>     > I then navigate to a .m file a click on it. Octave then shuts down.
>     I am not able to reproduce the crash.
>     Just to get the facts right:
>     When you try to open the file:
>     - you have "gedit" configured as custom editor
>     - you click on the open icon in the toolbar
>     - in the dialog box you navigate to the desired file and select it
>     - octave crashes
>     A few more questions:
>     - is gedit already open (you have selected "restore last session"
> This is not gedit related  -- I had exactly the same symptoms before I
> tried gedit.
>       in the settings)?
>     - in which state is the internal editor (shown, hidden, ...)?
>     - does octave crash when you use "edit file_name" instead?
> Wow this is interesting
>  I did edit d.m
> and it did not crash.
> and now I can use the gui mouse buttons and I can open and close d.m
> with no crashes.
> I then tried to open an old file with the mouse and got a crash
> I then did edit d1.m and it works fine with this d1.m file but still not
> with any old files.
> I can access all my old file with the edit command and then they work ok
> with the mouse clicks!!!!

Well, "interesting" is slightly understated ... :-)

Did you edit and save d.m when opened the first time via edit.m? If so,
is there a change in file permissions?
And you said it is not gedit related; but is it related to a custom
editor or does this also happen with the internal editor

It happens with the internal editor
-rw-rw-r--  1 doug doug         4 Nov  8 15:24 tt1a.m
-rw-rw-r--  1 doug doug         4 Nov 14 15:10 tt1 (copy).m
-rw-rw-r--  1 doug doug         4 Nov 14 15:10 tt1.m

It crashes with tt1.m and tt1 (copy).m but is ok with tt1a.m
the only difference among these files is the date!!!
I used ghex to look at them and they are the same.

If I create a new file with gedit separate from octave then this new file works ok

So the date seems to be the problem!!!!
Don't ask my why or how cus I don't know.
DASCertificate for 206392

reply via email to

[Prev in Thread] Current Thread [Next in Thread]