[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GL2PS] Build errors on default

From: Juan Pablo Carbajal
Subject: Re: [GL2PS] Build errors on default
Date: Thu, 9 Nov 2017 03:04:41 +0100

> These symbols should only be used if configure finds the gl2psLineJoin
> function.  Does it?  How?
> jwe

going back to the system's gl2ps I see that confure.log says

52528:configure:69611: checking for gl2psLineJoin
52529:configure:69611: gcc -o conftest -g -O2 -pthread -fopenmp
conftest.c -lgl2ps -lm   >&5
52530-configure:69611: $? = 0
52531-configure:69611: result: yes

I couldn't find what's the content of conftest.c by searching the m4
scripts. Any hint?

Anyways, by setting the links to 1.3.9 indeed gl2psLineJoin is deactivated:
/usr/lib/x86_64-linux-gnu/libgl2ps.so.1 -> libgl2ps.so.1.3.9
/usr/local/lib/libgl2ps.so.1 -> /usr/lib/x86_64-linux-gnu/libgl2ps.so.1.3.9

Instead of
/usr/lib/x86_64-linux-gnu/libgl2ps.so.1 -> libgl2ps.so.1.4.0
/usr/local/lib/libgl2ps.so.1 -> libgl2ps.so.1.4.0

It might be that there were residual links from previous 1.4.0 installations.

Sorry for taking your time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]