[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Re: [Pan-users] All the sudden, my Pan v0.12 broke on both of my Red

From: Phillip Pi
Subject: RE: Re: [Pan-users] All the sudden, my Pan v0.12 broke on both of my Red Hat Linux 7.x boxes!
Date: Tue, 25 Jun 2002 06:22:53 -0700 (PDT)

On Tue, 25 Jun 2002, address@hidden wrote:

> > So, does anyone know what's up with this? I guess Christophe is
> > currently busy to answer my post. :(
> Christophe does have a life of his own.

Yep, I can understand.

> > address@hidden download]$ pan
> > pan: relocation error: /usr/lib/ undefined symbol:
> > XRenderCompositeText8
> So, Xft is missing a dependency.  Check which ones:
>    $ rpm -qf /usr/lib/
>    (should return Xft which I believe you got from RawHide ?)

Xft- which I already have (latest too).

>    $ rpm -q --requires Xft

I got:
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

> This shows you all the dependencies of the Xft package.  Check if
> they're all satisfied (start with the packages, which are at the top,
> and have the form 'package' >= 'version').  There's probably an older
> version of a package on your system. By the looks of it, one of the
> XFree ones (could be wrong, though).

Ah, that's the key. I haven't upgraded XFree86: XFree86-4.0.3-5 because I 
would have upgrade my compiled Kernel. I think this is the problem? 
However, 7.2 box already has the latest kernel and XFree86. [confused]

> At this point I'd like to say that RawHide is looking like it's in flux.
> There seems to be limited binary compatibility with the 7.x series.  My
> guess is they've started working on 8.0.
> So, an alternative to upgrading all your packages to RawHide levels,
> would be to use Ximian: get all the gtk2 packages from Ximian and start
> over.
> Even better: upgrade your RH7.1 box to RH7.2 or 7.3. Since you're
> already using RedCarpet, you can them get the gnome2 snapshot packages
> (or rather, just the gtk2 packages) and let RedCarpet handle all the
> dependencies for you.

Isn't gnome2 still unstable? I don't want to upgrade gnome if it is still 
in beta.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]