[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pan-users] Glib dependency and nodeps?

From: Vadim Berezniker
Subject: Re: [Pan-users] Glib dependency and nodeps?
Date: Wed, 11 Jun 2003 14:58:02 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030415

Staci wrote:
Can I ADD the glib 2.0 libraries and keep my other ones too?  I believe my glib 
is 1.2.10, but above it seems to
be finding 2.0.x??  Am I reading that right?

(Incidentally, had this been an odd case, it would have been REALLY nice to be 
able to run configure as
"--nodeps" but you don't offer than option...a suggestion for the future.  I 
know it wouldn't solve this prob but
it could hypothetically solve a hypothetical prob in the future. ;) )

Yes, you need to install glib2 in order to install 0.14.
You can have both glib1 and glib2 installed at the same time w/o conflicts.

It would not be possible to have a --nodeps option for configure...
You're probably thinking of RPM dependencies, where you can use --nodeps to specify that you already have something installed (but not from RPM).

If a configure script cannot find a mandatory dependancy installed, that means something that the program requires is not found or not usable which would mean the program can't run.

Hope that helps.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]