[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Pan-users] Permissions Re: Aaarrrgghhh! Whahoppena Terminal??

From: Beartooth
Subject: [Pan-users] Permissions Re: Aaarrrgghhh! Whahoppena Terminal??
Date: Sat, 7 Mar 2009 16:09:45 +0000 (UTC)
User-agent: Pan/0.133 (House of Butterflies)

On Fri, 06 Mar 2009 19:52:47 -0600, Gerald L wrote:
> I was just interested to see if the was actually owned
> by you.
> You have some serious ownership/permissions issues on your system that
> are going to be VERY difficult to diagnose via email. There is
> absolutely no reason that kwrite should be the only editor able to open
> that file.
> I'd suspect the fact that you couldn't open it using gedit or anything
> else is also caused by whatever is making it fail to run every time from
> Pan.
> About the only way to even begin to troubleshoot at this point will be
> for you to sit down and start writing a book.
> Word-for-word, command-by-command, what you do from the time you turn on
> the machine to the time it fails to work correctly. You're not running
> the same distro I'm familiar with so it still will probably require the
> assistance of others.

        Oh double aaarrrgghhh -- plus rats, and then more rats! 

        Here's some background -- at length, with my apologies -- on 
that, in case it inspires anyone.

        I've been running one family of distros almost exclusively ever 
since I got into Linux with RedHat 6 or 7, upgrading to each new release 
when I can, and doing fresh installs whenever an upgrade fails. 

        When I get a newer bigger faster machine, the previous one gets 
demoted to #2, then 3, then 4, then out the door. #2 - 4 are essentially 
backitter-uppiters -- all the same apps installed, as nearly as I can 
manage it, and most of the same data, copying all I can, back and forth 
over the LAN or by sneakermail. All that naturally requires a lot of some 
kind of copying.

        When I manage to bollix one so badly that I can't get online with 
it (about every couple years), the others are ready to spring into the 

        But their actual use is to take some of the load off #1 by 
running stuff like weather and GPS/topo maps, where I don't need to c&p 
between what's running and anything else -- particularly Gmane/usenet 
groups and email.

        I used to use tar and scp to another machine to back up what I 
wanted to keep, whenever I did a fresh install. Then I discovered I was 
omitting a switch from my tar command, which affected permissions. 

        So I took to burning stuff to media, using K3B or Brasero, and 
copying it back, all by click-&-drag.

        Then  about Fedora 8 or 9, I started discovering permission 
trouble that way -- scattered, randomly afaict, all through /home/btth, 
and maybe also elsewhere. (I'm running Fedora 10 now.)

        Chown -R btth:btth /home/btth/* and chown -R btth:btth /home/
btth/.* don't seem to fix it. I run Gnome and metacity, no compiz; so I 
go from the desktop with nautilus (I guess it is -- clicking and 
dragging, anyhow), opening Properties > Permissions, looking for padlocks 
and getting rid of them.

        I think I understand the idea of permissions, but I can never 
keep the notation straight -- either kind of notation, with hyphens or 

        Otoh, nobody but me does anything with any of my machines; so I 
see no great increase of risk in opening permissions way up. I hope 
that's right. (My LAN is of course behind a router, and I run denyhosts 
except when I want to use ssh a/o scp between two. Ssh is set never to 
let anybody log in from outside the house.)

        So much for the general case, as background. As for present 
specifics, I'm really bewildered to hear I have permission trouble with 
files I have just created for the first time, as user.

        Maybe I need to go to the fedora list, a/o my LUG, and start a 
permissions thread -- if I can figure out how. Is it possible something 
is wrong with the way my userid is set up??

Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
Remember I know precious little of what I am talking about.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]