[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Pan-users] Re: Bug squashed

From: SciFi
Subject: [Pan-users] Re: Bug squashed
Date: Thu, 21 Jan 2010 07:22:12 +0000 (UTC)
User-agent: Pan/0.133 (House of Butterflies; SVNr370+549655+403797+541676+424083+351196+527313+579753+465763; i386-apple-darwin9.8.0)


Very sorry, other things keep getting in my way.  :(

I will need to do the tests over again, the cache etc here got cleaned-out.

When I upgrade stuff, I did have a "cheat sheet" to go thru each (sub)project
in sequence, just like a pkg-mgr would do (since I cannot trust 'em to use my
build env-vars properly y'know).

My main problem in upgrading anything here --

I do not see how we can have two different versions of gmime installed on the
same system.  Here is how it looks to us (with 2.2.23):


$ cd /usr/local/lib

$ ls -al *gmim*
-rw-r--r-- 1 root admin     240 Nov 21  2008
-rwxr-xr-x 1 root admin  510052 Nov 21  2008 libgmime-
lrwxr-xr-x 1 root admin      25 Nov 21  2008 libgmime-2.0.2.dylib -> 
-rw-r--r-- 1 root admin 1552520 Nov 21  2008 libgmime-2.0.a
lrwxr-xr-x 1 root admin      25 Nov 21  2008 libgmime-2.0.dylib -> 
-rwxr-xr-x 1 root admin    1091 Nov 21  2008

$ cat
# Configuration file for using the GMIME library in GNOME applications
GMIME_LIBS="-lgmime-2.0 -lz -liconv"

$ cat
# - a libtool library file
# Generated by - GNU libtool 1.5.26 (1.1220.2.492 2008/01/30 06:40:56)
# Please DO NOT delete this file!
# It is necessary for linking the library.

# The name that we can dlopen(3).

# Names of this library.
library_names='libgmime- libgmime-2.0.2.dylib 

# The name of the static archive.

# Libraries that this one depends upon.
dependency_libs=' -L/usr/local/lib /usr/local/lib/ 
/usr/local/lib/ /usr/local/lib/ 
/usr/local/lib/ /usr/local/lib/ -lbz2 -lreadline 
/usr/local/lib/ -lc -lz /usr/local/lib/'

# Version information for libgmime-2.0.

# Is this an already installed library?

# Should we warn about portability when linking against -modules?

# Files to dlopen/dlpreopen

# Directory that this library needs to be installed in:


Please remember I build everything old-fashionedly by my own hands.  ;)

When installing a newer gmime build, some of the pointers etc will change,
then some apps gripe about the lack of expected things etc, y'know.

I was trying to put on gmime-2.4.3 at one point.
Got into too much trouble afterwards.
That's when I stopped and re-installed 2.2.23,
while I began hollering in the related bug-report
since Pan officially still wasn't fixed fully at that time.

This has been the most irritating point of my trying to upgrade anything
dealing with X11 apps here.

Sorry, I just do not know how this would work here.


I wonder if I should wait for Mr.Kerr when he said, in late Sept'09, that he
wanted to switch Pan to use new(er) APIs etc to get ready for GNOME-3?
(Perhaps by that time OSX-10.6.x aka SnowLeopard would be better ready for
more open-src projects I hope.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]