[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Patch-gnuradio] make work with libtool 2.2

From: Eric Blossom
Subject: Re: [Patch-gnuradio] make work with libtool 2.2
Date: Tue, 17 Jun 2008 22:02:21 -0700
User-agent: Mutt/1.5.17 (2007-11-01)

On Tue, Jun 17, 2008 at 04:53:53PM -0400, Don Ward wrote:
> Libtool 2.2 appears to correctly handle interlibrary dependencies on Cygwin 
> and MinGW.  With libtool 2.2, we no longer need to apply patches to 
> Makefiles before building on these systems.
> Using libtool 2.2 with the current produces many lines of 
> warnings when the newly-deprecated AC_PROG_LIBTOOL macro is used in 
> conjunction with certain other macros (such as GR_FORTRAN).  We can avoid 
> the warnings and still be able to use either libtool 1.5 or 2.2 with the 
> attached one-line patch to  This should be considered a 
> temporary measure until we are ready to require users who need to run 
> bootstrap to upgrade to libtool 2.2.
> It would be convenient for Cygwin and MinGW users if future release 
> tarballs were prepared using libtool 2.2.  This would eliminate the need 
> for tarball users to install autotools and run ./bootstrap.
> -- Don W.

I applied the patch in r8613.  

I also applied it to gr-howto-write-a-block/  If this
isn't correct, please let me know.

Thanks again!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]