[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Phpgroupware-tracker] [Bug #519] Mail compose and send not function pro

From: nobody
Subject: [Phpgroupware-tracker] [Bug #519] Mail compose and send not function propertly
Date: Fri, 23 Aug 2002 11:04:55 -0400

=================== BUG #519: LATEST MODIFICATIONS ==================

Changes by: Ryan Nelson <address@hidden>
Date: 2002-Aug-23 15:04 (GMT)

------------------ Additional Follow-up Comments ----------------------------

I changed the value of file_upload to 'On' in php.ini and it works great now.  
Thank you for all of the help.

Ryan Nelson
Regina, SK, Canada

=================== BUG #519: FULL BUG SNAPSHOT ===================

Submitted by: None                      Project: phpGroupWare                   
Submitted on: 2002-May-31 20:01
Category:  email                        Bug Group:  0.9.14 RC3                  
Severity:  5 - Major                    Priority:  High                         
Resolution:  None                       Assigned to:  None                      
Status:  Open                           Platform Version:  Linux - RedHat       
Reproducibility:  Every Time            

Summary:  Mail compose and send not function propertly

Original Submission:  My phpgroupware functionality perfectly in RedHat 7.1,
I install 7.3 but the mail not function propertly, when try attach files, the 
file not is add to list of files attached and when send a email the system 

Your message could not be sent!
The mail server returned:

    [code] => 550
    [msg] => 5.1.1 <>... User unknown

    [desc] => [server_chat] => c->s: fsockopen(xx.xx.xx.xx,25,0,,5) ; returned: 
Resource id #26
s->c: 220 ESMTP Sendmail 8.11.6/8.11.6; Fri, 31 May 2002 
14:56:49 -0500
c->s: EHLO
s->c: Hello [xx.xx.xx.xx], pleased to meet 
s->c: 250-8BITMIME
s->c: 250-SIZE
s->c: 250-DSN
s->c: 250-ONEX
s->c: 250-ETRN
s->c: 250-XUSR
s->c: 250 HELP
c->s: MAIL FROM:<address@hidden>
s->c: 250 2.1.0 <address@hidden>... Sender ok
c->s: RCPT TO:<>
s->c: 550 5.1.1 <>... User unknown


All email values are blank.

excuseme my english is poor.

Follow-up Comments

Date: 2002-Aug-23 15:04             By: rynox

I changed the value of file_upload to 'On' in php.ini and it works great now.  
Thank you for all of the help.

Ryan Nelson
Regina, SK, Canada

Date: 2002-Aug-23 02:45             By: None
This comment is from angles,

Probably is this:

There are 2 ways to submit forms in the HTML world.

The default way is "application/x-www-form-urlencoded". This indicates a 
submit, php is cool with this.

The other way to submit a form is "multipart/form-data". This is a newer and 
complicated way to submit and is usually associated with file uploads (large 
Thus a "form enctype="multipart/form-data"" submit needs PHP.INI file to have
"file_uploads = On".

Older AngleMail and stock phpGW email send button used "multipart/form-data" 
caused problems when the php.ini file did not have "file_uploads = On", also it 
not an obvious thing to associate mail not sending with that setting in php.ini.

So recently I tested both submit types and "Send" now uses
"application/x-www-form-urlencoded" in more recent AngleMail versions which 
does not
require the "file_upload = On" setting, and the mail send works the same.

The user should upgrade to AngleMail (, or diff and its tpl
files, and change the form submit encoding as I described above.


Dave Hall

Date: 2002-Aug-22 16:42             By: rynox
In my php.ini the valus of register_globals was set to On.  I have also tries 
it with it set to Off, but with the same result: RCPT TO:<>.

I have tried a little more screwing aroung and have found if i edit and assign a value to $to in the file, it will send the 
message but everything else is missing i.e. the subject line and the message 

c->s: fsockopen(,25,0,,5) ; returned: Resource id #19
s->c: 220 -- Server ESMTP ("SaskTel Mail Service")
c->s: EHLO
s->c: 250-8BITMIME
s->c: 250-PIPELINING
s->c: 250-DSN
s->c: 250-XDFLG
s->c: 250-HELP
s->c: 250-TURN
s->c: 250-XLOOP 7230D743398483CF56CB6EBF1B186883
s->c: 250-ETRN
s->c: 250-RELAY
s->c: 250 SIZE 10485760
c->s: MAIL FROM:<address@hidden>
s->c: 250 2.5.0 Address Ok.
c->s: RCPT TO:<>
s->c: 553 5.1.3 bad address syntax: 

Could this be an issue with RedHat 7.3?


Date: 2002-Aug-22 00:55             By: None
Hi ryan,

Do you have register globals on in your php.ini??  Try chaning this and it 
should fix it.

Let me know how you go



Date: 2002-Aug-21 18:36             By: rynox

I have recently installed phpGroupWare on RedHat 7.3 and have had the very same 
problem.  Everything works great, I can receive email just fine but when I send 
I always get an error. This has occured with .12 .14 and .9 .  Looking at the 
tcpdump, everything is fine until it sends the RCPT TO: to the SMTP server - it 
always sends RCPT TO:<> although there is a address in the To: box.  Is the 
address getting lost or not getting passed to the send function?  I'm no 
programmer, but it just seems that the data gets lost that should be put in 
there.  Any suggestions?

Ryan Nelson

Date: 2002-Aug-21 06:25             By: skwashd
Hi None,

It looks like Douglas is right on this one.  Does this problem occur when a to 
address is supplied.  I know the system should be checking this before 
attempting to send.


Dave Hall

Date: 2002-Jun-09 22:11             By: None
Actually, attachemnt has nothing to do with this.  There is a problem parsing 
the header lines of the message to use in the "RCPT TO:"'ll notice 
it's <> blank.  You obviously can't send a blank e-mail.

Douglas Wagner

No files currently attached

For detailed info, follow this link:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]