[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS compilation difficulty

From: John Darrington
Subject: Re: CVS compilation difficulty
Date: Fri, 15 Dec 2006 08:01:02 +0900
User-agent: Mutt/1.5.9i

On Thu, Dec 14, 2006 at 02:13:07PM -0800, Daniel E WILLIAMS wrote:
     Hello, again.  I'm trying to compile the CVS repository code and have
     not had any success cracking the following error when running
     ./configure: line 13333: syntax error near unexpected token `GTK,'
     ./configure: line 13333: `  PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.6.0)'
     The offending region in the configure script is:
     if test x"$with_gui" != x"no" ; then
      PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.6.0)
      PKG_CHECK_MODULES(GLADE, libglade-2.0)
     Any ideas?  I'm using cygwin, in case that information helps.

This suggests that you don't have the pkg.m4 module.  However, if
you're not interested in building the GUI, then you can run configure
using "./configure --without-gui" and it should work just fine.

I've never yet successfully built the GUI under Cygwin.  I think there
are some subtleties of the linker which Cygwin hasn't got right.  But
the command line interface should be OK.


PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]