[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Knoppix results

From: Kyle Hayes
Subject: [Qemu-devel] Knoppix results
Date: Wed, 28 Jan 2004 22:11:00 -0800
User-agent: KMail/1.5.4

Here's my host system:

QEMU: 0.5.2 (binary from web site)
Linux:  Gentoo 1.4 up to date (stable)
CPU: Pentium 4 2.6 GHz (recent stepping)
Mem: 512MB DDR PC3200

I've tried to install Knoppix within QEMU.  I have had some luck, but not 
succeeded with everything.  I can boot it and it seems to run Linux without 
any problems as long as I do not try to use X Windows.  Where I have 
difficulties is when I try to install Knoppix onto the "hard disk".

Here's the command line I'm using:

qemu -hda hda.img -cdrom knoppix.iso -boot d -m 128

The disk image hda.img is initially blank. I created it with:

dd if=/dev/zero of=hda.img bs=1M count=4096

This produces a 4GB file full of zeros.

I them use the command line above to boot the Knoppix CD image.  I boot 
Knoppix with the following command line:

boot: knoppix lang=us 2

The "2" tells Knoppix to boot into command line mode, not graphical mode.  No 
GUI will be used.  I tried that, but Knoppix can't figure out X.  It sees a 
generic VESA-type card, but cannot actually use it for some reason.  

Knoppix boots and I get a command prompt.  Everything looks OK at this point.  
I can look at directories and start and stop things.  I cannot run any 
graphical tools but that wasn't my aim at this point.

I can launch cfdisk from within Knoppix.  However, it is somewhat hit or miss 
whether or not I can partition the disk image that I created.  I can usually 
do one partition write and that is it.  On the second one, I seem to have a 
strong change of having QEMU hang while using 100% of the CPU.  So, some 
problem with disk IO?

After a couple of tries, I got the disk image ready and partitioned.  Whenever 
cfdisk hung QEMU, I had to kill the emulator and restart the process. I found 
that the changes that were successfully written to the disk image were good, 
so I was able to make forward progress.

I then launched knx-hdinstall.  This script installs Knoppix onto the hard 
drive.  I get though initial setup (I can skip through the partitioning 
because I did that separately) including formatting the hard disk image and 
preparing the swap space.  When it gets to the stage where it is copying 
files from the Knoppix CD image to the hard disk image, it hangs using 100% 
of the CPU before it completes copying the files.  

I attempted knx-install twice.  The first time it got to 30% complete and 
hung.  The second time it got to 9%.  I tried a third time while I was 
writing this email and the screen saver kicked in.  The screen (well, the 
window) went black and nothing I typed would restart it.  I was able to 
release the mouse (it had been grabbed into the window) and was able to kill 
off QEMU.  I guess I need to figure out how to stop the screen saver :-)

The first two times, I don't think the screen saver started before it hung.  
The first time, I was able to release the mouse from QEMU.  The second time I 
didn't have the mouse grabbed by QEMU.

How can I help debug this?  It seems very, very close.  The only common theme 
I can see between by two cases of hanging is disk IO.  In the case of cfdisk, 
it is low level disk IO and may be calling some weird things to write to the 
partition table (you wouldn't think so, but there's something odd about it).  
The second case, knx-hdinstall, seems to simply cause a lot of disk IO.  
Perhaps "interrupts" are being lost or something?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]