[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Sound and MinGW problems on Windows host

From: Sylvain Petreolle
Subject: Re: [Qemu-devel] Sound and MinGW problems on Windows host
Date: Wed, 7 Jul 2004 21:08:42 +0200 (CEST)

Hi Tomasz,

I have the same configuration here (WinXP Home host / Freedos guest).
It plays modules in ScreamTracker as if they were open in Winamp.
(sound is mono though ;)
Make sure you have correct setup for adress/irq/dma/hdma
and try to change the software, some use still unimplemented DSP commands.

> 1. Sound is very choppy. And I mean _very_. It's not usable at all.
> Under Linux there's no problem.
> 2. Sound only works at 22050 Hz, setting 44100 make it go silent.

Make sure you applied sound patch to enable it in MinGW
and check the output of configure.
> 3. As Natalia Portillo noticed in different thread, compiling CVS
> under MinGW creates the binary, but it's only runnable under MinGW
> itself, directly under windows command prompt it exits immediatelly.
> There'd be no problem, but within MinGW the sound doesn't work at all.
> I tried patches from http://www.h7.dion.ne.jp/~qemu-win/,
> but without any success.

Sylvain Petreolle (spetreolle_at_users_dot_sourceforge_dot_net)
Say NO to software patents
Dites NON aux brevets logiciels

"You believe it's the year 1984, when in fact, its closer to 2184"1984 / Matrix


Créez gratuitement votre Yahoo! Mail avec 100 Mo de stockage !
Créez votre Yahoo! Mail sur http://fr.benefits.yahoo.com/

Dialoguez en direct avec vos amis grâce à Yahoo! Messenger !Téléchargez Yahoo! 
Messenger sur http://fr.messenger.yahoo.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]