[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] QEMU floppy problems (was: ecos and qemu)

From: Karel Gardas
Subject: Re: [Qemu-devel] QEMU floppy problems (was: ecos and qemu)
Date: Fri, 23 Jul 2004 18:03:53 +0200 (CEST)

On Fri, 23 Jul 2004, Johannes Martin wrote:

> On Fri, 23 Jul 2004, Ben Pfaff wrote:
> > > For a while I thought it wasn't since not all apps worked. I think now
> > > it is a problem with the floppy code(either in qemu or in ecos). The
> > > apps are built as bootable floppy images and some of them were lacking
> > > sectors so parts of the image were NULLs leading to crashes. If I turn
> > > those same floppy images to bootable iso-s using mkisofs and run
> > > qemu-cdrom on them they work all the time.
> > That's very interesting.  At least part of the problem I've had with
> > Windows NT 3.51 appears to be floppy-related.  I'll have to see if I can
> > try anything similar.
> I've got floppy problems in OS/2 and Win98 as well. Booting the
> installation floppies and a win98 boot floppy both works fine, but from a
> fully installed version of OS/2 and Win98 installed on disk I cannot
> access the floppies at all.
> The difference: booting probably goes through int13 on all systems, i.e.
> through the bios, but once OS/2 and Win98 later access floppies by
> programm the fdc directly. So maybe there's a bug in that part of the
> emulation.

That's really interesting, since few weeks ago, when I was playing with
Solaris9/x86 in Qemu I've not been able to mount floppy into this OS by
volcheck command (as docs say that's for mounting floppy) and so I gave up
and used cdrom and manually created isos for transfering necessary tarbals
to my solaris9 installation...


Karel Gardas                  address@hidden
ObjectSecurity Ltd.           http://www.objectsecurity.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]