[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] W2K SP0 Status - mmx build

From: Joe Bogner
Subject: [Qemu-devel] W2K SP0 Status - mmx build
Date: Mon, 17 Jan 2005 15:38:02 -0500

I'm having trouble executing qemu after compiling on w2k pro. I
downloaded the 0.6.1 source and followed the porting instructions.
Everything compiled (although I had to use SDL-1.2.8-devel because SDL
wouldn't compile). I'm getting a segfault when I run the compiled
binary. The official release of 0.6.1 works fine on my machine (with
the same image). The version I compiled won't even show the BIOS
before crashing...

Here's the GDB results:

$ gdb qemu.exe
GNU gdb 5.2.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-mingw32"...
(gdb) set args -L c:/progra~1/qemu/bios -hda c:/virtual/temp.img
(gdb) r
Starting program: c:\dev\qemu\qemu-0.6.1\i386-softmmu/qemu.exe -L
    mu/bios -hda c:/virtual/temp.img

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) backtrace
#0  0x00000000 in ?? ()
#1  0x0044e414 in cpu_x86_exec (env1=0x0)
    at c:/dev/qemu/qemu-0.6.1/cpu-exec.c:540

I also had the same results with the CVS source. My goal is to enable
MMX in the windows build so I can attempt to install MDAC/.NET
Framework on my windows 2000 pro image. My image works great except
that I get an access violation when attempting to install the .NET
framework. I read on here that lack of MMX support could be at fault.

Does anyone have any suggestions on what I should try? I've been
fighting with this for at least 5 hours.... Or, I'd be grateful if
someone could just create a windows build with MMX enabled (as
specified below).


From:  Tim 
Subject:  [Qemu-devel] W2K SP0 Status (was: Re: 2.6.10-mm3: swsusp:
out of memory on resume)
Date:  Sat, 15 Jan 2005 13:02:14 -0500 
User-agent:  Mutt/1.5.6+20040907i 


> I did not enable SSE and MMX for x86 because I fear there are still bugs 
> which may cause regressions. Interested people can enable the line:
> --
>      env->cpuid_features |= CPUID_FXSR | CPUID_MMX | CPUID_SSE | 
> --
> and see if their OS and application still work.

I am using exclusively x86 on x86 (target=i386-softmmu).

I just booted one of my older win2k images without this enabled.
Everything came up fine, and I am still stuck with the SP4 installer
(spews the same "an error has occured" that I have reported in the
past.)  No change here.

Then I added the two lines you mention in target-i386/helper2.c, and
recompiled.  Upon booting this old image again, everything worked as
expected.  I tried installing SP4 and I got the same old error.  So,
this initial test showed no difference with MMX et al. enabled.  (I was
hoping that MMX capabilities would fix their SP4 installer, but no
luck there.) 

Next, I kept MMX stuff enabled, and began installing win2k with an image
of the install CD.  The disk is partitioned and formatted fine.  After
the first reboot, and round of hardware detection, I get the dreaded
"not enough space on disk" error.  It gives me the software selection
screen, and it indicates there is 0 space left on disk.  I don't
remember how I got around this last time.  I'll keep trying.  (fyi- I
created this image with 'qemu-img win2k.img 3G'.)

In short, I don't see any differences so far, besides the disk issue
that comes and goes for those installing Win2k.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]