[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] KQEMU bus errors

From: Darryl Dixon
Subject: Re: [Qemu-devel] KQEMU bus errors
Date: Sun, 13 Feb 2005 22:42:37 +1300


    I'm not convinced that this is actually the case.  I have tested this on several machines now with several guest OSes and get the same result on all of them (which all previously worked).  With the snapshot from 2005-02-09 all works correctly.  With CVS from 2005-02-11 onwards I get the error ('Bus error' on host for WinXP guest and 'Protection Fault' inside guest for Win98 guest).  I think that perhaps with smaller guest RAM size you are simply hiding the bug.  On one machine at least I have 756MB physical RAM and 3GB swap allocated and get the same problem.  Most of the references that I can find for a Linux 'Bus error' talk about unaligned memory accesses.  I did a diff of the 2005-02-09 tree and the 2005-02-11 tree and noted that most of the *changes* (rather than additions and new things) were relating to the way that memory is handled and marked inside qemu.  I think that there is a chance that one of these has introduced the problem.


On Sun, 2005-02-13 at 09:14 +0400, Brad Campbell wrote:
Hetz Ben Hamo wrote:
> Yes, found the reason...
> Test with different ram size - you'll be surprised...
I second this one.
I found I had to make sure my tmpfs "partition" was larger than my requested ram size. Problem went 

Darryl Dixon <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]