[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Solaris (9 and 10) supported on 0.6.1?

From: Celso Pinto
Subject: Re: [Qemu-devel] Solaris (9 and 10) supported on 0.6.1?
Date: Fri, 22 Apr 2005 11:11:41 +0100 (WEST)
User-agent: SquirrelMail/1.4.4

>> I just pulled the source from CVS and applied the mentioned patch
> Which patch?

hmmm not the one you just sent. Taking a look at this patch, the only code
I patched was:
@@ -500,6 +506,10 @@
 static inline void ide_set_irq(IDEState *s)
     if (!(s->cmd & IDE_CMD_DISABLE_IRQ)) {
+        BMDMAState *bm = s->bmdma;
+        if(bm)
+            bm->status |= BM_STATUS_INT;

+    pci_conf[0x09] = 0x8a; // programming interface = PCI_IDE bus master
is supported

I'll surely give it one more go ASAP with this patch and your use cases,
as I'm really keen on getting this working.

To be honest, I can't thank you enough for sharing your knowledge on this


Celso Pinto <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]