qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Dynamic bridging


From: Paul Brook
Subject: Re: [Qemu-devel] Dynamic bridging
Date: Wed, 18 May 2005 13:55:50 +0100
User-agent: KMail/1.7.2

On Wednesday 18 May 2005 01:52, Ben Taylor wrote:
> I was trying to get the bridging working (with the help
> of pbrook and nox- on the irc #qemu channel) and
> eventually got it working under Sun JDS/3 (Suse 9.1)
> after adding the bridge-util's rpm.
>
> After some experimentation, I found that once I setup
> the bridge on my primary interface, (eth0) and I used
> the qemu-ifup script, the tunnels would automatcially
> attach to the bridge, and when qemu shuts down, they
> automatically go away.
>
> primary-ifup
> Code:
>
> #!/bin/sh
> /sbin/brctl addbr br0
> /sbin/ifconfig eth0 0.0.0.0 promisc up
> /sbin/ifconfig eth0 192.168.1.2 netmask 255.255.255.0 broadcast \
>   192.168.1.255 up

This line should be changes to ifconfig br0 ...., and moved to the end of the 
script. 

You shouldn't give the component devices an IP address, just the br interface. 
Using the component interfaces directly is liable to lead to weird problems 
on the host.

Also, if youdon't want to use a static IP, you can just run dhclient
(or equivalent) on the br0 interface as normal.

My setup looks someting like:

/sbin/brctl addbr br0
/sbin/ifconfig eth0 0.0.0.0 up
/sbin/brctl addif br0 eth0
dhclient br0

Paul




reply via email to

[Prev in Thread] Current Thread [Next in Thread]