[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] What happened to linuxppc-img from Freeoszoo

From: jeebs
Subject: Re: [Qemu-devel] What happened to linuxppc-img from Freeoszoo
Date: Fri, 24 Jun 2005 14:21:04 -0500

"Tero Kaarlela"

>    I tried to boot linuxppc image from freeoszoo with QemuCVS. kernel 
> boots ok but then I get errors that it cant read filesystem from dev hda.
>    Also tried with 0.7.0 and it freezes at: Freeing unused kernel memory

What's the date of the disk image itself?

Late last year, QEMU reworked the disk geometry, and that can confuse old 
disk images.  The images expect an old style and the newer qemu offers a 
different geometry.

qemu now more closely does what a real system does.  But I think somebody in 
the qemu user forum came across a situation where it wasn't true.  Don't 
remember the details, but I think it was for 512m sizes.  I don't remember 
well, so I could be wrong.  Anyway, it works better now than it did before.

Somebody with lots of bandwidth needs to go through those old images and see 
if they still work right.

We know for certain the ReactOS image doesn't work anymore and needs to be 
replaced.  I don't think anybody has gotten around to replacing it, though. 
And since ReactOS is so small and installs so easily, there hasn't been a 
great need to update it.

If you can figure out what the geometry was on the disk image, then you can 
use the -hdacs command line option to tell qemu to use those settings.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]