[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] fdisk give wrong number for losetup

From: Jim C. Brown
Subject: Re: [Qemu-devel] fdisk give wrong number for losetup
Date: Thu, 7 Jul 2005 09:10:54 -0400
User-agent: Mutt/1.4i

On Thu, Jul 07, 2005 at 12:36:08PM +0200, octane indice wrote:
> Hello
> I have some trouble using losetup to mount partitions
> from the host.

I never realized how difficult it was to interpret error messages written in
a foreign language.

> And now, my questions: why this?

Because you were passing the wrong value as the offset. You have to multipy
the cylinder with the number of heads and number of sectors per head and such.

> what's this number given by sfdisk: 516096 ?

Apparently, head*sectors per head*bytes per sector ... my fdisk doesn't show
that number though.

> fdisk doesn't give the good values?
> thanks

It does, but they are hard to interpret unless you understand disk geometries.

I really recommend using lomount or some similar tool to figure out these
offsets for you. (Incidently, lomount doesn't care about disk geometry - it
uses the absolute sector values in the partition table.)

> ---------------------------------------------
> Etes vous un consom'Acteur ? Toutes les saveurs ?quitables sont sur 
> http://www.epicerie-equitable.com
> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]