[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu vs gcc4

From: Rob Landley
Subject: Re: [Qemu-devel] qemu vs gcc4
Date: Sun, 29 Oct 2006 23:35:54 -0500
User-agent: KMail/1.9.1

On Monday 23 October 2006 1:58 pm, Paul Brook wrote:
> > Although, all told, it would seem to me that what might be called for
> > here is a new gcc target.  A gcc target specifically for generating qemu
> > code.  That would just simply generate whatever qemu wanted for function
> > postamble.
> Better to just teach qemu how to generate code.
> In fact I've already done most of the infrastructure (and a fair amount of 
> legwork) for this. The only major missing function is code to do softmmu 
> load/store ops.
> https://nowt.dyndns.org/

So given that one of the reasons for doing this would be getting away from 
depending on specific and increasily out of date versions of gcc to build the 
thing, what would be involved in getting this version to build under gcc-4.x?

(I tried, and it didn't...)

"Perfection is reached, not when there is no longer anything to add, but
when there is no longer anything to take away." - Antoine de Saint-Exupery

reply via email to

[Prev in Thread] Current Thread [Next in Thread]