[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 0/5] Enable building of op.o on gcc4

From: Alexander Graf
Subject: Re: [Qemu-devel] [PATCH 0/5] Enable building of op.o on gcc4
Date: Fri, 18 Jan 2008 07:14:38 +0100

On Jan 17, 2008, at 11:34 PM, Ismail Dönmez wrote:

Thursday 17 January 2008 19:00:11 tarihinde şunları yazmıştınız:

On Thu, 17 Jan 2008, Ismail Dönmez wrote:
Thanks but ppc target doesn't work here with gcc 4.3 trunk , i686- linux :

gcc -mtune=native -march=native -O2 -pipe -fomit-frame-pointer
-Wstrict-overflow -Wall -O2 -g -fno-strict-aliasing -fomit-frame- pointer
-I. -I.. -I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/target-ppc
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1 -MMD -MP -DNEED_CPU_H
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/linux-user/ppc - D_GNU_SOURCE
-DHAS_AUDIO_CHOICE -I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/ slirp -c
-o cpu-exec.o /var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/cpu-exec.c
../dyngen -g -o gen-op.h op.o
dyngen: ret or jmp expected at the end of op_divw

This is for ppc-linux-user .

Does not happen for me, with gcc 4.1.2 on OpenSUSE 10.2.

Also arm-linux-user is broken :

gcc -mtune=native -march=native -O2 -pipe -fomit-frame-pointer
-Wstrict-overflow -Wall -O2 -g -fno-strict-aliasing -I. -I..
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1 -MMD -MP -DNEED_CPU_H
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/linux-user/mips - D_GNU_SOURCE
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/fpu  -DHAS_AUDIO
-I/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/slirp    -c -o helper.o
/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/target-arm/op_iwmmxt.c: In
function 'op_iwmmxt_movq_wRn_M0':
/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/target-arm/op_iwmmxt.c:176: error:
unable to find a register to spill in class 'GENERAL_REGS'
/var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/target-arm/op_iwmmxt.c:176: error:
this is the insn:
(insn:HI 8 17 18
2 /var/pisi/qemu-0.9.1-9/work/qemu-0.9.1/target-arm/op_iwmmxt.c: 175 (set
(mem/s/j:DI (plus:SI (plus:SI (mult:SI (reg/f:SI 59)
                       (const_int 8 [0x8]))
                   (reg/f:SI 58 [ env.2032 ]))
(const_int 4 [0x4])) [0 <variable>.iwmmxt.regs S8 A32])
       (reg:DI 60 [ <variable>.iwmmxt.val ])) 63 {*movdi_2}
(expr_list:REG_DEAD (reg:DI 60 [ <variable>.iwmmxt.val ])
       (expr_list:REG_DEAD (reg/f:SI 59)
           (expr_list:REG_DEAD (reg/f:SI 58 [ env.2032 ])
confused by earlier errors, bailing out

I do not get this error, either.

Might be a GCC 4.3 thing :-/


Never learn by your mistakes, if you do you may never dare to try again.

This looks rather like an old version of the patch. Are you sure you did a ./configure after applying the newest version of the patch (the one that modifies the configure script)?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]