[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [qemu 0.9.1] broken build system

From: C.W. Betts
Subject: Re: [Qemu-devel] [qemu 0.9.1] broken build system
Date: Sat, 2 Feb 2008 13:04:19 -0700

Don't set host-cc. It can be gcc4. The current qemu configure script will look for an alternate version of GCC if the "gcc" program is version 4. It should find your gcc 3.4 executable. ----- Original Message ----- From: "solsTiCe d'Hiver" <address@hidden>
To: <address@hidden>
Sent: Saturday, February 02, 2008 4:19 AM
Subject: [Qemu-devel] [qemu 0.9.1] broken build system

i am trying to compile qemu 0.9.1 on archlinux 64 (x86_64)

when i try to compile it with :
./configure --prefix=/usr --enable-alsa --host-cc=gcc-3.4 
ppc-softmmu sparc-softmmu x86_64-softmmu arm-softmmu mips-softmmu"

avoiding all the *-user target as specified in the original PKGBUILD i use,
because they do not compile on x86_64 (???)

i got this error:
gcc-3.4  -m64 -Wl,-T,/home/solstice/abs/qemu/src/qemu-0.9.1/x86_64.ld -g -o
qemu vl.o osdep.o monitor.o pci.o loader.o isa_mmio.o block-raw-posix.o
lsi53c895a.o usb-ohci.o eeprom93xx.o eepro100.o ne2000.o pcnet.o rtl8139.o
ide.o pckbd.o ps2.o vga.o sb16.o es1370.o dma.o fdc.o mc146818rtc.o serial.o i8259.o i8254.o pcspk.o pc.o cirrus_vga.o apic.o parallel.o acpi.o piix_pci.o
usb-uhci.o vmmouse.o vmport.o vmware_vga.o gdbstub.o ../libqemu_common.a
libqemu.a -lm -lz -lasound -lgnutls -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -lrt -lpthread -lutil /usr/bin/ld: warning: libdl.so.2, needed by /usr/lib/libasound.so, not found
(try using -rpath or -rpath-link)
/usr/lib/libSDL.so: undefined reference to address@hidden'
/usr/lib/libasound.so: undefined reference to address@hidden'
/usr/lib/libSDL.so: undefined reference to address@hidden'
/usr/lib/libasound.so: undefined reference to address@hidden'
/usr/lib/libasound.so: undefined reference to address@hidden'
/usr/lib/libasound.so: undefined reference to address@hidden'
collect2: ld returned 1 exit status
make[1]: *** [qemu] Error 1
make[1]: Leaving directory
make: *** [subdir-i386-softmmu] Error 2

a linking problem ?
$ locate libdl

and /usr/lib/libdl.so is a symlink towards /lib/libdl.so.2
if i make a symlink:
ln -s /usr/bin/libdl.so /usr/bin/libdl.so.2

it works ! until the next bug

if i try to walk around that bug without that symlink i had to patch the
config-host.mak to had a rpath toward /lib. well, i don't know how it's work.
i simply used the error message and grep for rpath in src directory
i can't fix the configure or whatever.

i got similar error when i try to compile *-user target but this time with
libz.so.1. i do not make a symlink here... i am not gonna fix the build
system by making symlink all around

WAIT ! i am not finished ;-)

and by the way, it fixes one problem but i got another one:
install -m 755 -s qemu-system-mips "/home/solstice/abs/qemu/pkg/usr/bin"
make[1]: Leaving directory
ERROR: unknown option --host-cc
Usage: ./configure [options]

Options include:
   --arch=ARCH            architecture to compile for (x86_64)
   --cross-prefix=PREFIX  prefix for cross compile
   --prefix=PREFIX        where to install things (/usr)
   --with-patched-kernel  don't use external module
   --kerneldir=DIR        kernel build directory
   --qemu-cc=CC           specify compiler for qemu (must be gcc-3.x)
   --qemu-cflags=CFLAGS   CFLAGS to add to qemu configuration
   --qemu-ldflags=LDFLAGS LDFLAGS to add to qemu configuration

Any additional option is given to qemu's configure verbatim; including:

   --disable-gcc-check    don't insist on gcc-3.x
                          CAUTION: this will break running without kvm
   --disable-werror       disable compilation abort on warning
   --disable-sdl          disable SDL
   --enable-cocoa         enable COCOA (Mac OS X only)
   --enable-mingw32       enable Win32 cross compilation with mingw32
   --enable-adlib         enable Adlib emulation
   --enable-coreaudio     enable Coreaudio audio driver
   --enable-alsa          enable ALSA audio driver
   --enable-fmod          enable FMOD audio driver
   --enable-dsound        enable DirectSound audio driver
   --disable-vnc-tls      disable TLS encryption for VNC server
Makefile:1: ../config.mak: No such file or directory
make: *** No rule to make target `../config.mak'.  Stop.
==> ERROR: Build Failed.

--host-cc is not recognize here. but wait we're installing and a configure
option get in the way... i really do not understand anything ....

reply via email to

[Prev in Thread] Current Thread [Next in Thread]