[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] c99 or not?

From: Andreas Färber
Subject: Re: [Qemu-devel] c99 or not?
Date: Thu, 21 Aug 2008 21:43:10 +0200

Am 18.08.2008 um 01:34 schrieb Ben Taylor:

On Sun, Aug 17, 2008 at 7:28 PM, Anthony Liguori <address@hidden > wrote:
Ben Taylor wrote:

I've been hacking about on qemu again on Solaris 10, which I've run
into an issue.

in the nbd.h file, it includes stdbool.h, but on Solaris 10, you have
to enable c99
to get this to compile.

Are you not using GCC? QEMU is not known to support any compilers other
than GCC.

gcc-3.4.3.  though once the tcg conversion is complete, I want to
give studio 12 a whirl.

Perhaps you need to specify -std=gnu99 instead of -std=c99?

I'll give that a shot.

-std=gnu99 takes me further on S10, but compilation fails in cpu- exec.c:694 with "error: bp cannot be used in asm here".

There are also a lot of redefinition warnings for isnormal, isgreater etc. between Solaris' math[_c99].h and softfloat[_native].h.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]