[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu-img commit -- is there a limit on file sizes?

From: Anthony Liguori
Subject: Re: [Qemu-devel] qemu-img commit -- is there a limit on file sizes?
Date: Mon, 01 Dec 2008 11:14:08 -0600
User-agent: Thunderbird (X11/20080925)

walt wrote:
Some background for my question:  I've been trying to install
and then update Windows Vista using kvm.  Everything works great
until I use 'qemu-img commit' to apply all the Windows Updates
to my original base install of Vista.

After doing the qemu-img commit step, the backing file is now
corrupt, 100% reproducibly.  I don't have the same problem with
Windows XP, however, and I wondered if the problem is caused by
the sheer size of the commit that Vista requires.

When I install XP, then windows-update, and then qemu-img commit
the updates, I'm committing about 1GB of updates to a 3GB backing

When I install Vista and then later commit the Vista updates, I'm
committing a 3GB file to a 6GB backing file, and that's when the
corruption happens every time.

So I tried an experiment with Vista -- I deliberately limit the
number of windows updates I allow at any one time, and then use
qemu-img commit after each small update.  Voila, everything now
works perfectly -- no file corruption!

We've started getting some reports of corruption on "commit" in KVM. There is a long standing disk corruption issue too that is very difficult to reproduce. The thinking is that there is a bug somewhere in the qcow2 code.

Is anyone actively looking into this?


Anthony Liguori

And that's why I suspect there is a functional limit to the size
of each commit I can do with qemu-img.

Any thoughts or possible diagnostic maneuvers to be tried?


(BTW, I get the same results using 32-bit linux and 64-bit linux
on the same amd64 machine, using both gcc3 and gcc4.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]