[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] ARMv6 el + vfp: User Mode signals uncaught target signa

From: Martin Mohring
Subject: Re: [Qemu-devel] ARMv6 el + vfp: User Mode signals uncaught target signal 4 (Illegal instruction)
Date: Fri, 05 Dec 2008 13:35:13 +0100
User-agent: Thunderbird (X11/20081112)

Laurent Desnogues wrote:
> On Fri, Dec 5, 2008 at 11:17 AM, Martin Mohring
> <address@hidden> wrote:
>> I put together a qemu from recent svn trunk -r 5862.
>> when running armv6 eabi + vfp binaries in user mode emulation, i get:
>> qemu: uncaught target signal 4 (Illegal instruction) - exiting
>> running the same compiled for armv5 eabi + vfp works. I use the binaries
>> from mojo (mojo.handhelds.org) project, they ported Ubuntu 8.04 to arm.
>> They also have a compiled version for ARMv6 + VFP, which I wanted to try
>> in the openSUSE Buildservice.
> You should specify the CPU when launching qemu.  Look at "qemu -cpu ?"
> output and select the right one. You probably want -cpu arm1136.
I use qemu user mode, and call qemu with host linux kernels binfmt
handler. How do I specify the cpu type there? Or must I compile in the
"default cpu type" somehow?
>> How do I find out whats wrong? From the source code, I would guess qemu
>> is implemented up to ARMv7, right?
> Yes ARMv7 is in, including NEON.
I thought that, from looking into the code. I was sure I missed something...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]