[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Small powerpc system emulation problem with linux

From: Lennart Sorensen
Subject: Re: [Qemu-devel] Small powerpc system emulation problem with linux
Date: Wed, 14 Jan 2009 18:08:38 -0500
User-agent: Mutt/1.5.13 (2006-08-11)

On Wed, Jan 14, 2009 at 05:37:16PM +0100, Aurelien Jarno wrote:
> First of all, please retry with the current SVN, a lot of things have
> been fixed.

But it has only been a couple of days.  :)

> This is a known problem, looks like there is a problem with IO ports. You
> can workaround the problem by using an other card, like e1000.

Or using 2.6.26 worked too.  Maybe 2.6.18 did something wrong.

> The machine that is emulated is actually a g3beige, that is an OldWorld
> machine. Installing quik on such machine is correct. Note that the
> current version of debian installer installs a totally buggy quik.conf
> file. It has to be fixed manually.

Ehm, linux kernel detected it as a g3blue&white.  I wonder why it would
misdetect it that way.

> Quik is now working correctly with the current SVN.

Oh OK.  I will try updating and then redoing the install with quik.

> No, this is actually normal, as an OldWorld machine is emulated.

Yeah so I noticed.  Still made me confused since the machine type
detected by the linux kernel is supposed to be newworld, but it also
detects the machine as oldworld.  So qemu bug or linux kernel bug?

> The machine in ppc_oldworld.c is an OldWorld machine. There has been
> some mistakes in both OpenBIOS and QEMU, that should now be fixed.

OK, I will try an update and see what happens.

> We plan to emulated a NewWorld machine using ppc_chrp.c as a basis when
> all the problem with the OldWorld machine have been solved.

Oh OK.  Given the progress on ppc emulation since 0.9.1, I am sure it
won't be long before that is all working very well.

Len Sorensen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]