[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] vmmouse

From: andrzej zaborowski
Subject: Re: [Qemu-devel] vmmouse
Date: Fri, 30 Jan 2009 00:20:20 +0100

2009/1/29 Anthony Liguori <address@hidden>:
> Rick Vernam wrote:
>> On Thursday 29 January 2009 2:58:27 pm you wrote:
>>> In article <address@hidden> you write:
>>>> For the past few days (10-15, longer?) both my windows vms seem to have
>>>> broken mice - the mouse cursor does not move in the guest...
>>>> Both guests run windows (2k,xp) and both have vmware mouse driver
>>>> installed (not sure which version, off the top of my head).
>>>> I've not followed the list too closely during this time period either -
>>>> in
>>>> trying to catch up tonight I haven't seen anything on this subject, so
>>>> I'm
>>>> posting to see if this is a known issue...
>>>> I built qemu with DEBUG_VMMOUSE turned on in hw/vmmouse.c.
>>>> When I run qemu I get a single vmmouse_init right when qemu starts, but
>>>> then no additional output.
>>>> Perhaps this is a separate issue, but when I "usb_add tablet" the mouse
>>>> cursor becomes constrained to the upper left corner of the guests'
>>>> screen.
>>>> Any ideas about what might be going on?
>>>> Thanks
>>> `It's dead, Jim!' ;)
>>>  Yeah, I had reported vmmouse brokenness before (for linux guests):
>>>        http://lists.gnu.org/archive/html/qemu-devel/2009-01/msg01061.html
>>>  I guess its good (in a way) you confirm its broken for windows
>>> guests too...
>>>        Juergen
>> It seems the brokenness extends beyond the mouse - the arrow keys on the
>> keyboard are not behaving correctly either, although the arrows on the
>> keypad are working correctly.
> Arrow keys are a separate problem.  I wasn't aware that vmmouse was having
> problems.  Does anyone know what changeset broke it?

I hit the issue with the generic tablet.  Hopefully fixed it in r6476.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]