[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu working openbsd/sparc64 yet?

From: Vivek Ayer
Subject: Re: [Qemu-devel] qemu working openbsd/sparc64 yet?
Date: Thu, 2 Apr 2009 21:40:11 -0700

How did you build it without getting an error in sdl.c specifically at
X11/Xlib.h? I tried disabling sdl and it built fine, but the images
weren't loading, so I thought I'd go with the default options except
for the target list.


On Wed, Apr 1, 2009 at 3:17 PM, Vivek Ayer <address@hidden> wrote:
> okay i guess it doesn't build the x86_64 target either. So looks like
> I'm stuck with SPARC/Solaris. Can't even install Linux on the SPARC
> emulator because MATLAB wouldn't install.
> Vivek
> On Wed, Apr 1, 2009 at 2:29 PM, Vivek Ayer <address@hidden> wrote:
>> Wait, does openbsd/sparc64 build x86_64 fine? That would be better
>> than sparc and sparc64.
>> Vivek
>> On Wed, Apr 1, 2009 at 12:58 PM, Vivek Ayer <address@hidden> wrote:
>>> Wait...I'm confused. The i386 emulation builds ok? I tried building
>>> with all emulation options and it wouldn't build.
>>> Suppose I went with your options: ./configure
>>> --target-list="sparc-softmmu sparc64-softmmu sparc64-bsd-user
>>> This would allow me to emulate which guests exactly? You got Linux to
>>> run, but that's Sparc/Linux and MATLAB wouldn't install on that.
>>> Because the MATLAB license can only install on Linux (i386), Linux
>>> (x86-64), OSX (Intel), Solaris 64, and Windows . So the QEMU install
>>> would be limited to emulating openbsd/sparc64, linux/sparc64,
>>> linux/sparc, and solaris/opensolaris.
>>> Considering the install options, I'm just limited to using Solaris 64,
>>> right? Which would I could only run solaris/opensolaris on
>>> openbsd/sparc64 to install matlab, right?
>>> Just want to make sure,
>>> Vivek
>>> On Wed, Apr 1, 2009 at 11:42 AM, Blue Swirl <address@hidden> wrote:
>>>> On 4/1/09, Vivek Ayer <address@hidden> wrote:
>>>>> what were your configure options? I'm getting an error using gmake at
>>>>>  i386-softmmu. I'm checking out the svn code to see if that's better.
>>>>>  If you can send me the build that you got working that'd be great. I
>>>>>  just need Linux on OpenBSD/sparc64 so I can go ahead and use MATLAB
>>>>>  and Mathematica.
>>>> I guess those are x86 versions. The i386 emulator does not work on
>>>> Sparc because unaligned accesses are not handled yet by the code
>>>> generator. But it should build all right.
>>>> I just use something like
>>>> ./configure --target-list="sparc-softmmu sparc64-softmmu sparc64-bsd-user"
>>>> and I get shell prompt with the sparc-test Linux setup on sparc-softmmu.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]