[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] unknown keycodes `xfree86(abnt2)_aliases(qwerty)'

From: Carlos A. M. dos Santos
Subject: [Qemu-devel] unknown keycodes `xfree86(abnt2)_aliases(qwerty)'
Date: Sun, 12 Apr 2009 23:02:14 -0300


Each time I start qemu I see this message:

    unknown keycodes `xfree86(abnt2)_aliases(qwerty)', please report
to address@hidden

This is harmless, as far as I can tell, since the keyboard still works
correctly. I'm reporting just because qemu asks me to do it. :-)

Here is a summary of my environment:

- FreeBSD 7-STABLE, updated on March 29
- kqemu-kmod-devel-1.4.0.p1_2
- qemu-0.10.2
- xorg-server-1.5.3_7,1

My xorg.conf configures the keyboard to Brazilian Portuguese layout
(a.k.a. ABNT2):

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbRules"  "xorg"
        Option      "XkbModel"  "abnt2"
        Option      "XkbLayout" "br"

The message goes away if I invoke qemu with "-k pt-br" but if in this
case I see "Warning: no scancode found for keysym 314" when  I press
an accent dead key. This is a known problem, according to what I found
searching in list archives.

I do not subscribe qemu-devel so please CC'me in your answers.

My preferred quotation of Robert Louis Stevenson is "You cannot
make an omelette without breaking eggs". Not because I like the
omelettes, but because I like the sound of eggs being broken.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]