[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH] kvm: Improve upgrade notes when facing unsuppor

From: Avi Kivity
Subject: [Qemu-devel] Re: [PATCH] kvm: Improve upgrade notes when facing unsupported kernels
Date: Sun, 07 Jun 2009 12:38:39 +0300
User-agent: Thunderbird (X11/20090320)

Jan Kiszka wrote:
Users complained that it is not obvious what to do when kvm refuses to
build or run due to an unsupported host kernel, so let's improve the

diff --git a/configure b/configure
index 42d46f2..8ccb58c 100755
--- a/configure
+++ b/configure
@@ -1158,7 +1158,9 @@ EOF
        | grep "error: " \
        | awk -F "error: " '{if (NR>1) printf(", "); printf("%s",$2);}'`
       if test "$kvmerr" != "" ; then
-        kvm="no - (${kvmerr})"
+        kvm="no - (${kvmerr})\n\
+    NOTE: To enable KVM support, update your kernel to 2.6.29+ or install \
+recent kvm-kmod from http://sourceforge.net/projects/kvm.";

Installing kvm-mod is insufficient, you need the headers from somewhere.

Do not meddle in the internals of kernels, for they are subtle and quick to 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]