[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Re: Breakage with local APIC routing

From: Mohammed Gamal
Subject: Re: [Qemu-devel] Re: Breakage with local APIC routing
Date: Tue, 25 Aug 2009 12:09:34 +0300

qemu-system-x86_64 -hda /dev/null -cdrom <path_to_ubuntu_iso_image>

I was using qemu-kvm, but I assume that using -no-kvm would be
equivalent to using plain qemu, no?

On Tue, Aug 25, 2009 at 11:59 AM, Jan Kiszka<address@hidden> wrote:
> Mohammed Gamal wrote:
>> On Tue, Aug 25, 2009 at 9:56 AM, Jan Kiszka<address@hidden> wrote:
>>> Johannes Schindelin wrote:
>>>> Hi,
>>>> On Sun, 17 Aug 2008, Jan Kiszka wrote:
>>>>> Johannes Schindelin wrote:
>>>>>> On Wed, 13 Aug 2008, Jan Kiszka wrote:
>>>>>>> Johannes Schindelin wrote:
>>>>>>>> due to the change in revision 3371 (well, at that time, CVS was used,
>>>>>>>> which was no better than Subversion) installation of win64 is broken
>>>>>>>> in QEmu.  The commit message reads like this:
>>>>>>>>   Don't route PIC interrupts through the local APIC if the local
>>>>>>>>   APIC config says so. By Ari Kivity.
>>>>>>> I recalled some earlier post on this which claimed to fix the issue and
>>>>>>> found it in the archive:
>>>>>>> http://permalink.gmane.org/gmane.comp.emulators.qemu/25415
>>>>>> I tried this, and it changes the symptoms, indeed.  Instead of an endless
>>>>>> loop, it results in a bluescreen.
>>>>>> As the OP said that it worked for him, I guess it is either in commits
>>>>>> that came after his post, or in my add-on patches.
>>>>> So we are likely on the wrong path. Maybe we have to understand what
>>>>> happens here first...
>>>>>> Hopefully I will find some time to work more on this bug.
>>>>> Would be interesting to know
>>>>>  - if pic_irq_request is continuously called or if it stops when windows
>>>>>    hangs
>>>>>  - what IRQ vectors are delivered
>>>>>  - in what state the apic is, namely the s->lvt[APIC_LVT_LINT0]
>>>> Sorry for the long delay.  I just don't have time to take care of the
>>>> issue, but I quickly verified that it still does not work, with aa0cba4
>>>> (Aug 13 2009).
>>>> If you are still interested in this issue, could you give me a hint
>>>> _where_ I should output _which_ values?  I'll gladly take time for that
>>>> now.
>>> If some OS does not properly install due to a possible emulation bug, I
>>> am interested, for sure. Let's restart this by specifying the test case
>>> more precisely: What version of Windows are you trying to install? What
>>> is your qemu command line? Where does the installation fail? Are there
>>> specific steps required during the installation to reproduce the problem?
>>> And one more question: Did you check that you were using the
>>> corresponding BIOS to aa0cba4?
>>> Jan
>> In case this is considered relevant. I am also facing a bug with
>> installing amd64 version of ubuntu-9.04. I first thought it was a
>> possible bug in KVM, but even when using -no-kvm the guest still hangs
>> just when starting to load the kernel.
> Might be the same, might be a different issue. Same questions to you:
> what is your command line, and are there specific steps required to
> reproduce the issue? And I assume you also tried plain qemu, right?
> Jan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]