[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Re: How to use -acpitable to add a SLIC-table?

From: Michael Tokarev
Subject: Re: [Qemu-devel] Re: How to use -acpitable to add a SLIC-table?
Date: Wed, 28 Oct 2009 13:12:40 +0300
User-agent: Mozilla-Thunderbird (X11/20090706)

Replying to an old email...

Stefan Hellermann wrote at 30-Mar-2009:
Gleb Natapov schrieb:
On Thu, Mar 26, 2009 at 06:35:16PM +0100, Stefan Hellermann wrote:

how can I use the -acpitable parameter to add a SLIC-table to the
qemu-bios dynamically?

I think I need a file with the SLIC-data, but how can I extract this
data out of my BIOS from my host-machine for example?

The -acpitable parameter accepts a bunch of settings and a datafile, do
I need to set all these settings? I think most of them should sit in the

-acpitable parameter settings are field from common ACPI table header.
If you skip any of them default will be used. Table data that goes after
headers should be specified after data=.

I tried using SLIC-Data-files downloaded from the web, but I'm unsure if
they are formatted correctly.
It looks like they already contain ACPI header.
Okay, I did some new tries. On my own (real-)machine I did
# acpidump -o acpidata
# acpixtract -l dump | grep SLIC
Signature Length  OemId     OemTableId   OemRevision CompilerId
    SLIC     374  "LENOVO"  "TP-7O   "    00002210    " LTP"     00000000
# acpixtract -sSLIC acpidata
# qemu-system-x86_64 -acpitable
sig=SLIC,rev=1,oem_id=LENOVO,oem_table_id=TP-70\ \ \

But this doesn't work either. I diffed the output of acpidump with the
-acpitable parameter and without, the results are the same.
I compared my own SLIC.dat file with the ones I downloaded from the web,
the first bytes of the files look similar. I think they are in the same
-acpitable data=SLIC.aml or SLIC.bin doesn't throw an error, but the
linux-kernel in the virtual machine doesn't detect new acpi-tables. I
attached a hexdump from these two files.
How do you know they are not detected. Can you send acpidump output?

I checked the start of dmesg-output, i think it lists (all?)
acpi-tables. On my real-machine there is a line
ACPI: SLIC 7F6CBE62, 0176 (r1 LENOVO TP-7O        2210  LTP        0)
In the qemu-vm there is no such line.

#qemu-system-x86_64 -help | head -n 1
QEMU PC emulator version 0.10.0 (kvm-devel), Copyright (c) 2003-2008
Fabrice Bellard

Stefan, Was you able to actually specify an externa SLIC table with qemu?
The thread I'm replying to is quite old and it ends prematurely without
any definitive result.  I tried it in qemu-0.11.0 and qemu-kvm-0.11.0,
but it looks like -acpitable gets ignored the same way as it was in
0.10.0 as you observed.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]