[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Stack corruption problem with SeaBIOS/gPXE under QEMU

From: Kevin O'Connor
Subject: Re: [Qemu-devel] Stack corruption problem with SeaBIOS/gPXE under QEMU
Date: Fri, 20 Nov 2009 19:47:02 -0500
User-agent: Mutt/1.5.19 (2009-01-05)

On Tue, Nov 17, 2009 at 03:23:46PM +0200, Avi Kivity wrote:
> On 11/17/2009 04:26 AM, Kevin O'Connor wrote:
>> On Mon, Nov 16, 2009 at 04:02:20PM +0200, Avi Kivity wrote:
>>>> Something that is likely related, I am seeing reboot failures in
>>>> seabios's pmm_free.  Immediately after loading gpxe, seabios is in an
>>>> endless loop there, likely due to memory corruption.
>>>> This is with -smp 2, rebooting Fedora 9 after installation.
>>> With gpxe disabled, rebooting works as expected.
>>> Note the tests were performed with the stack at 64K to avoid triggering
>>> the known issue.
>> Hi Avi,
>> Can you send the full qemu command line that you used?  I can't seem
>> to reproduce this on my setup.

Hi Avi,

I'm still unable to reproduce this Fedora reboot failure.

> Example command line is

That command looks like the vista cdrom scenario.  To try and
reproduce the fedora reboot issue, I checked out 51a8ac6f of qemu-kvm
and ran:

qemu-img create -f qcow2 test-fc9 10G

qemu-system-x86_64 -hda test-fc9 -cdrom 
../../iso/Fedora-9-i386-DVD/Fedora-9-i386-DVD.iso -m 512 -smp 2

This was with the bios.bin that came with 51a8ac6f.  I selected all
default options (except I disabled "Software productivity tools" to
make the install go faster).  The machine rebooted okay after the

Can you retry this with the latest seabios git.  If you are able to
reproduce, can you set CONFIG_DEBUG_LEVEL to 8 and post the log?
Maybe something in the log will help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]