[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 646427] Re: VirtFS mapped symlinks resolved wrong

From: Moshroum
Subject: [Qemu-devel] [Bug 646427] Re: VirtFS mapped symlinks resolved wrong
Date: Fri, 24 Sep 2010 20:35:02 -0000

Host OS is Debian sid/experimental amd64 with 2.6.32-5-amd64
(2.6.32-23). qemu-kvm version can be found above. As said before the
symlink were created outside the vm and then tried to access inside the

So I have to use passthrough in host/client shared folders... which
means I have to run kvm as root. :(

VirtFS mapped symlinks resolved wrong
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

Status in QEMU: New

Bug description:
I tried to map a folder with qemu-kvm qemu-kvm-0.13.0-rc1-3-gc9c2179 (this is 
v0.13.0-rc1-16667-gc9c2179). I mounted it first in passthrough mode and saw all 
symlinks as expected. Then I used mapped and noticed that the target of a 
symlink changed to the actual data inside the linked folder as target instead 
of the target filename.

So for example if you have a file abc with the content "omg, this is important 
stuff" and a symlink lnkme -> abc then it wiill look inside the kvm with 
mounted 9p virtio (mapped) like that:

lnkme -> omg, this is important stuff

Another problem I noticed was that I cannot mount it (mapped or passthrough) 
using /etc/rc.local or /etc/fstab, but after login as root using

mount /mnt


mount -t 9p -o trans=virtio host_share /mnt

(the same stuff i tried inside /etc/rc.local)

The only output on a failed mount in rc.local/fstab I get is 

[   15.035920] device: '9p-1': device_add
[   15.038180] 9p: no channels available
[   15.038937] device: '9p-1': device_unregister
[   15.049123] device: '9p-1': device_create_release

reply via email to

[Prev in Thread] Current Thread [Next in Thread]