[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Snapshots ide0-hd0 issue

From: Ubuntu Explorer
Subject: Re: [Qemu-devel] Snapshots ide0-hd0 issue
Date: Tue, 19 Oct 2010 08:51:42 +0900

Thanks for your help.

But, after commenting out snapshot option, I still cannot save the VM state into the ide0-hd0 block device.

Here is some more information about the problem.

I am trying to do the following
a. info block
    shows virtio, ide0-hd0
b. savevm snapshot_name
c. info snapshots
    Shows snapshot_name under virtio
d. commit ide0-hd0
e. quit
f. Check timestamp of ide0 file - no change. ( I assume that qemu would write something to this file)
g. restart qemu.
h. info snapshots
i. No snapshots in "virtio"

I will try to run qemu in gdb mode to see why commit is not committing the changes to the ide0-hd0 block device.
But any other information will be helpful as well. I have googled a lot without much luck.


On Mon, Oct 18, 2010 at 3:17 PM, Stefan Hajnoczi <address@hidden> wrote:
On Mon, Oct 18, 2010 at 12:37 AM, Ubuntu Explorer
<address@hidden> wrote:
> I am trying to implement snapshot saving and loading from command line using
> qemu. I am using both the drive and disk options as follows.
> <qemu exe> \
> --disk <path to disk file> \
> ...other options \
> -drive file=<path to drive file>,
> index=0,media=disk,snapshot=on,if=ide,type=drive,cache=writethrough

Remove snapshot=on.  See the documentation about -snapshot versus
savevm snapshots:


"When using the (unrelated) -snapshot option (Snapshot mode), you can
always make VM snapshots, but they are deleted as soon as you exit


reply via email to

[Prev in Thread] Current Thread [Next in Thread]