[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 1/1] Add QMP bits for blockdev-snapshot-sync.

From: Jes Sorensen
Subject: Re: [Qemu-devel] [PATCH v2 1/1] Add QMP bits for blockdev-snapshot-sync.
Date: Thu, 28 Apr 2011 16:38:02 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110307 Fedora/3.1.9-0.39.b3pre.fc14 Thunderbird/3.1.9

On 04/28/11 16:36, Anthony Liguori wrote:
> On 04/27/2011 10:05 AM, Luiz Capitulino wrote:
>> On Mon, 18 Apr 2011 16:27:01 +0200
>> address@hidden wrote:
>>> From: Jes Sorensen<address@hidden>
>>> This is quivalent to snapshot_blkdev in the human monitor, with _sync
>>> added to the command name to make it explicit that the command is
>>> synchronous and leave space for a future async version.
>> I'm not sure appending "_sync" is such a good convention, most commands
>> are sync today and they don't have it. I'd prefer to call it
>> snapshot_blkdev
>> and note in the documentation how it works.
> It probably should be called snapshot_blkdev_broken because that's what
> it really is.
> The '_sync' is there to indicate that this command doesn't properly
> implement asynchronous logic and can break a guest.
> I'd actually prefer that we not expose this command through QMP at all
> and instead implement a proper snapshot command.

Sorry but this is utterly bogus.

The snapshot support as is works fine, and the command is in the
monitor. We should expose it in QMP as well.

If we eventually get a different implementation, then we can rename it
or replace it then.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]