[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCHv2 6/7] cleanup qemu_co_sendv(), qemu_co_recvv()

From: Paolo Bonzini
Subject: Re: [Qemu-devel] [PATCHv2 6/7] cleanup qemu_co_sendv(), qemu_co_recvv() and friends
Date: Sun, 11 Mar 2012 16:01:35 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.1) Gecko/20120216 Thunderbird/10.0.1

Il 11/03/2012 02:49, Michael Tokarev ha scritto:
> The same as for non-coroutine versions in previous patches:
> rename arguments to be more obvious, change type of arguments
> from int to size_t where appropriate, and use common code for
> send and receive paths (with one extra argument) since these
> are exactly the same.  Use common qemu_sendv_recvv() directly.
> Also constify buf arg of qemu_co_send().
> qemu_co_sendv(), qemu_co_recvv(), and qemu_co_recv() are now
> trivial #define's merely adding one extra arg.  qemu_co_send()
> is an inline function due to `buf' arg de-constification.

Again, I don't see the point in using #defines.  Either leave the
function static, or you can export it but then inlines are preferrable.

> qemu_co_sendv() and qemu_co_recvv() callers are converted to
> different argument order.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]