qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] target-mips: Use EXCP_SC rather than a magic nu


From: Aurelien Jarno
Subject: Re: [Qemu-devel] [PATCH] target-mips: Use EXCP_SC rather than a magic number
Date: Tue, 1 Jan 2013 12:07:08 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

On Thu, Dec 20, 2012 at 10:14:20AM +0800, 陳韋任 (Wei-Ren Chen) wrote:
> Hi Li,
> 
> > > > Signed-off-by: Chen Wei-Ren <address@hidden>
> > > > ---
> > > >  target-mips/op_helper.c |    6 +++---
> > > >  1 files changed, 3 insertions(+), 3 deletions(-)
> > > > 
> > > > diff --git a/target-mips/op_helper.c b/target-mips/op_helper.c
> > > > index f45d494..98a445c 100644
> > > > --- a/target-mips/op_helper.c
> > > > +++ b/target-mips/op_helper.c
> > > > @@ -39,10 +39,10 @@ static inline void QEMU_NORETURN 
> > > > do_raise_exception_err(CPUMIPSState *env,
> > > >                                                          uintptr_t pc)
> > > >  {
> > > >      TranslationBlock *tb;
> > > > -#if 1
> > > > -    if (exception < 0x100)
> > > > +    if (exception < EXCP_SC) {
> > > >          qemu_log("%s: %d %d\n", __func__, exception, error_code);
> > > > -#endif
> > > > +    }
> > > > +
> > 
> > seems original '#if 1, #endif' statement
> > is  for temporary debug only,
> > so maybe can be concealed out entirely.
> > for log purpose, every exception code
> > will log when 'do_interrupt' for MIPS
> > if log is enabled.
> 
>   Thanks for your feedback. You mean the code snippet below?
> 
> --- target-mips/helper.c
> void do_interrupt (CPUMIPSState *env)
> {
>     ...
> 
>     if (qemu_log_enabled() && env->exception_index != EXCP_EXT_INTERRUPT) {
>         if (env->exception_index < 0 || env->exception_index > EXCP_LAST)
>             name = "unknown";
>         else
>             name = excp_names[env->exception_index];
> 
>         qemu_log("%s enter: PC " TARGET_FMT_lx " EPC " TARGET_FMT_lx " %s 
> exception\n",
>                  __func__, env->active_tc.PC, env->CP0_EPC, name);
>     }
> 
>     ...
> }
> 

I don't think this is necessary to add a qemu_log_enabled(), this is
already something included in qemu_log().

-- 
Aurelien Jarno                          GPG: 1024D/F1BCDB73
address@hidden                 http://www.aurel32.net



reply via email to

[Prev in Thread] Current Thread [Next in Thread]