qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 1/8] CODING_STYLE: Section about conditional


From: Gonglei (Arei)
Subject: Re: [Qemu-devel] [PATCH v3 1/8] CODING_STYLE: Section about conditional statement
Date: Mon, 4 Aug 2014 00:55:42 +0000

Hi,

> > Yoda conditions lack readability, and QEMU has a
> > strict compiler configuration for checking a common
> > mistake like "if (dev = NULL)". Make it a written rule.
> >
> > Signed-off-by: Gonglei <address@hidden>
> > ---
> >  CODING_STYLE | 14 ++++++++++++++
> >  1 file changed, 14 insertions(+)
> >
> > diff --git a/CODING_STYLE b/CODING_STYLE
> > index 4280945..b08bfb4 100644
> > --- a/CODING_STYLE
> > +++ b/CODING_STYLE
> > @@ -91,3 +91,17 @@ Mixed declarations (interleaving statements and
> declarations within blocks)
> >  are not allowed; declarations should be at the beginning of blocks.  In
> other
> >  words, the code should not generate warnings if using GCC's
> >  -Wdeclaration-after-statement option.
> > +
> > +6. Conditional statements
> > +
> > +When comparing a variable for (in)equality with a constant, list the
> > +constant on the right, as in:
> > +
> > +if (a == 0) {
> > +    /* Reads like: "If a is equal to 0" */
> 
> I actually tend to read it as 'if a equals 0'.
> 
OK.

> > +    do_something();
> > +}
> > +
> > +Rationale: Yoda conditions (as in 'if (0 == a)') are awkward to read.
> 
> I know this is my suggested text, but now that I'm re-reading it, I'd
> recommend s/0/1/ in all three places, since comparison to 0 is one of
> those special cases where '!a' is faster to write than 'a == 0'.
> 
Got it.

> > +Besides, good compilers already warn users when '==' is mis-typed as '=',
> > +even when the constant is on the right.
> 
> With those changes,
> Reviewed-by: Eric Blake <address@hidden>
> 
OK, thanks!

Best regards,
-Gonglei

reply via email to

[Prev in Thread] Current Thread [Next in Thread]