[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] VirtIO windows driver: viostor.sys not post-installable

From: Yan Vugenfirer
Subject: Re: [Qemu-devel] VirtIO windows driver: viostor.sys not post-installable
Date: Sun, 31 May 2015 11:26:06 +0300

Adding Vadim to the thread.

On May 29, 2015, at 5:43 PM, Philipp Hahn <address@hidden> wrote:


we tried to migrate some Windows 2008 and 2012 VMs from Xen to KVM, but
installing the VirtIO viostor.sys driver fails, because the signature of
the driver doesn't seem to match what's stored in the corresponding .cat

Can you send the error message you are getting from Windows? If possible attach setupapi.log as well (search your system for setupapi.*, the location might be different for different OS versions).

On the other hand installing the drivers during a fresh install from the
beginning never had any problems.

We use
but also tried "virtio-win-0.1.103.iso" and "virtio-win-0.1-81.iso".

Running the following command on 0.1.104 prints (among others) the
following sha1hash:
"C:\Program Files (x86)\Windows Kits\8.1\bin\x86\signtool.exe" /verify
/v /kp E:\NetKVM\2k12\amd64\netkvm.sys
Hash of file (sha1): 135E3AA23217610AEE8046F68550B0BA86F4EAE6

"C:\Program Files (x86)\Windows Kits\8.1\bin\x86\signtool.exe" /verify
/v /kp E:\viostor\2k12\amd64\viostor.sys
Hash of file (sha1): EF11F5E539EEE0A9DB6DF3710A0DAA35066C5607

Looking into the corresponding .cat "Security Catalog File"
- netkvm.cat contains the above given hash for netkvm.sys,
- viostor.cat contains 55FC4DA2EE96ECC3FD4865680436DCDA6B8C6BDD instead!

Running "sha1sum" on Linux print some completely different hashes, so I
don't know what the Microsoft tool actually hash:

# sha1sum /cdrom/NetKVM/2k12/amd64/netkvm.sys /cdrom/viostor/2k12/amd64/viostor.sys
1aa91c8e1d7680457d92c1875810a79f68af536d  /cdrom/NetKVM/2k12/amd64/netkvm.sys
f39bc2b561091addfcac30e370227c91700d2698  /cdrom/viostor/2k12/amd64/viostor.sys

Is this a known issue?

There was some mismatch  reported between Windows and sha1sum on Linux.

Are there some (working) alternatives?

Are there some Linux tools to work with the .cat files and signatures to
make sure they match?

Is there some better mailing list for VirtIO Windows driver issues?

Vadim and I monitor qemu-devel, you can also open bug in bugzilla.redhat.com for virtio-win component or report an issue here: https://github.com/YanVugenfirer/kvm-guest-drivers-windows/issues

Some more background for our migration procedure:

- The VM was installed some years are on Xen.
- The GPLPV drivers were added afterwards.
- For the migration the GPLPV drivers were disabled and then removed.
- A 2nd VirtIO hard-disk was added in KVM to trigger Windows to request
the virstor driver.

If you need any more data, just ask.

Thanks in advance
Philipp Hahn

PS: data was copied by hand from Windows, so it might contains
Philipp Hahn
Open Source Software Engineer

Univention GmbH
be open.
Mary-Somerville-Str. 1
D-28359 Bremen
Tel.: +49 421 22232-0
Fax : +49 421 22232-99

Geschäftsführer: Peter H. Ganten
HRB 20755 Amtsgericht Bremen
Steuer-Nr.: 71-597-02876

reply via email to

[Prev in Thread] Current Thread [Next in Thread]