qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCHv7 5/9] slirp: Generalizing and neutralizing vari


From: Thomas Huth
Subject: Re: [Qemu-devel] [PATCHv7 5/9] slirp: Generalizing and neutralizing various TCP functions before adding IPv6 stuff
Date: Wed, 10 Feb 2016 09:35:31 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.0

On 08.02.2016 11:28, Samuel Thibault wrote:
> From: Guillaume Subiron <address@hidden>
> 
> Basically, this patch adds some switch in various TCP functions to
> prepare them for the IPv6 case.
> 
> To have something to "switch" in tcp_input() and tcp_respond(), a new
> argument is used to give them the sa_family of the addresses they are
> working on.
> 
> This patch does not include the entailed reindentation, to make proofread
> easier. Reindentation is adressed in the following no-op patch.
> 
> Signed-off-by: Guillaume Subiron <address@hidden>
> Signed-off-by: Samuel Thibault <address@hidden>
> ---
>  slirp/ip_input.c   |  2 +-
>  slirp/slirp.c      |  6 ++++--
>  slirp/slirp.h      |  5 +++--
>  slirp/tcp_input.c  | 52 ++++++++++++++++++++++++++++++++++++++++++++--------
>  slirp/tcp_output.c | 14 +++++++++++---
>  slirp/tcp_subr.c   | 37 +++++++++++++++++++++++++++++--------
>  slirp/tcp_timer.c  |  3 ++-
>  7 files changed, 94 insertions(+), 25 deletions(-)
...
> diff --git a/slirp/tcp_input.c b/slirp/tcp_input.c
> index 26b0c8b..0cc279b 100644
> --- a/slirp/tcp_input.c
> +++ b/slirp/tcp_input.c
> @@ -214,7 +214,7 @@ present:
>   * protocol specification dated September, 1981 very closely.
>   */
>  void
> -tcp_input(struct mbuf *m, int iphlen, struct socket *inso)
> +tcp_input(struct mbuf *m, int iphlen, struct socket *inso, unsigned short af)
>  {
>       struct ip save_ip, *ip;
>       register struct tcpiphdr *ti;
> @@ -256,6 +256,8 @@ tcp_input(struct mbuf *m, int iphlen, struct socket *inso)
>       }
>       slirp = m->slirp;
>  
> +     switch (af) {
> +     case AF_INET:
>       if (iphlen > sizeof(struct ip )) {
>         ip_stripoptions(m, (struct mbuf *)0);
>         iphlen=sizeof(struct ip );
> @@ -297,6 +299,11 @@ tcp_input(struct mbuf *m, int iphlen, struct socket 
> *inso)
>       if(cksum(m, len)) {
>         goto drop;
>       }
> +     break;
> +
> +     default:
> +         goto drop;
> +     }
>  
>       /*
>        * Check that TCP offset makes sense,
> @@ -332,14 +339,20 @@ tcp_input(struct mbuf *m, int iphlen, struct socket 
> *inso)
>        * Locate pcb for segment.
>        */
>  findso:
> -     lhost.ss_family = AF_INET;
> +     lhost.ss_family = af;
> +     fhost.ss_family = af;
> +     switch (af) {
> +     case AF_INET:
>       lhost4 = (struct sockaddr_in *) &lhost;
>       lhost4->sin_addr = ti->ti_src;
>       lhost4->sin_port = ti->ti_sport;
> -     fhost.ss_family = AF_INET;
>       fhost4 = (struct sockaddr_in *) &fhost;
>       fhost4->sin_addr = ti->ti_dst;
>       fhost4->sin_port = ti->ti_dport;
> +         break;
> +     default:
> +         goto drop;
> +     }
>  
>       so = solookup(&slirp->tcp_last_so, &slirp->tcb, &lhost, &fhost);
>  
> @@ -389,8 +402,17 @@ findso:
>         so->lhost.ss = lhost;
>         so->fhost.ss = fhost;
>  
> -       if ((so->so_iptos = tcp_tos(so)) == 0)
> +       so->so_iptos = tcp_tos(so);
> +       if (so->so_iptos == 0) {
> +           switch (af) {
> +           case AF_INET:
>           so->so_iptos = ((struct ip *)ti)->ip_tos;

I think you could also indent this here immediately ... it's only one
line, so indenting immediately should not hurt readability here.

> +               break;
> +           default:
> +               goto drop;
> +               break;
> +           }
> +       }
>  
>         tp = sototcpcb(so);
>         tp->t_state = TCPS_LISTEN;
> @@ -569,7 +591,8 @@ findso:
>          * If this is destined for the control address, then flag to
>          * tcp_ctl once connected, otherwise connect
>          */
> -       if ((so->so_faddr.s_addr & slirp->vnetwork_mask.s_addr) ==
> +       if (af == AF_INET &&
> +           (so->so_faddr.s_addr & slirp->vnetwork_mask.s_addr) ==
>             slirp->vnetwork_addr.s_addr) {
>           if (so->so_faddr.s_addr != slirp->vhost_addr.s_addr &&
>               so->so_faddr.s_addr != slirp->vnameserver_addr.s_addr) {
> @@ -607,7 +630,7 @@ findso:
>           if(errno == ECONNREFUSED) {
>             /* ACK the SYN, send RST to refuse the connection */
>             tcp_respond(tp, ti, m, ti->ti_seq+1, (tcp_seq)0,
> -                       TH_RST|TH_ACK);
> +                       TH_RST|TH_ACK, af);
>           } else {
>             if(errno == EHOSTUNREACH) code=ICMP_UNREACH_HOST;
>             HTONL(ti->ti_seq);             /* restore tcp header */
> @@ -616,7 +639,13 @@ findso:
>             HTONS(ti->ti_urp);
>             m->m_data -= sizeof(struct tcpiphdr)+off-sizeof(struct tcphdr);
>             m->m_len  += sizeof(struct tcpiphdr)+off-sizeof(struct tcphdr);
> +           switch (af) {
> +           case AF_INET:
>             *ip=save_ip;

Could also be indented immediately.

> +               break;
> +           default:
> +               goto drop;
> +           }
>             icmp_send_error(m, ICMP_UNREACH, code, 0, strerror(errno));
>           }
>              tcp_close(tp);
> @@ -1289,11 +1318,11 @@ dropafterack:
>  dropwithreset:
>       /* reuses m if m!=NULL, m_free() unnecessary */
>       if (tiflags & TH_ACK)
> -             tcp_respond(tp, ti, m, (tcp_seq)0, ti->ti_ack, TH_RST);
> +             tcp_respond(tp, ti, m, (tcp_seq)0, ti->ti_ack, TH_RST, af);
>       else {
>               if (tiflags & TH_SYN) ti->ti_len++;
>               tcp_respond(tp, ti, m, ti->ti_seq+ti->ti_len, (tcp_seq)0,
> -                 TH_RST|TH_ACK);
> +                 TH_RST|TH_ACK, af);
>       }
>  
>       return;
> @@ -1484,7 +1513,14 @@ tcp_mss(struct tcpcb *tp, u_int offer)
>       DEBUG_ARG("tp = %p", tp);
>       DEBUG_ARG("offer = %d", offer);
>  
> +     switch (so->so_ffamily) {
> +     case AF_INET:
>       mss = min(IF_MTU, IF_MRU) - sizeof(struct tcphdr) + sizeof(struct ip);

dito, indent immediately.

> +         break;
> +     default:
> +         break;
> +     }
> +
>       if (offer)
>               mss = min(mss, offer);
>       mss = max(mss, 32);
> diff --git a/slirp/tcp_output.c b/slirp/tcp_output.c
> index 7fc6a87..62ab1e5 100644
> --- a/slirp/tcp_output.c
> +++ b/slirp/tcp_output.c
> @@ -61,7 +61,8 @@ tcp_output(struct tcpcb *tp)
>       register long len, win;
>       int off, flags, error;
>       register struct mbuf *m;
> -     register struct tcpiphdr *ti;
> +     register struct tcpiphdr *ti, tcpiph_save;
> +     struct ip *ip;
>       u_char opt[MAX_TCPOPTLEN];
>       unsigned optlen, hdrlen;
>       int idle, sendalot;
> @@ -447,13 +448,15 @@ send:
>        * the template, but need a way to checksum without them.
>        */
>       m->m_len = hdrlen + len; /* XXX Needed? m_len should be correct */
> +     tcpiph_save = *(mtod(m, struct tcpiphdr *));
>  
> -     struct tcpiphdr tcpiph_save = *(mtod(m, struct tcpiphdr *));
> +     switch (so->so_ffamily) {
> +     case AF_INET:
>       m->m_data += sizeof(struct tcpiphdr) - sizeof(struct tcphdr)
>                                            - sizeof(struct ip);
>       m->m_len  -= sizeof(struct tcpiphdr) - sizeof(struct tcphdr)
>                                            - sizeof(struct ip);
> -     struct ip *ip = mtod(m, struct ip *);
> +     ip = mtod(m, struct ip *);
>  
>       ip->ip_len = m->m_len;
>       ip->ip_dst = tcpiph_save.ti_dst;
> @@ -464,6 +467,11 @@ send:
>       ip->ip_tos = so->so_iptos;
>  
>       error = ip_output(so, m);
> +         break;
> +
> +     default:
> +         goto out;

Hmm, this jumps to a "return (error)" statement ... but as far as I can
see, error has never been initialized in this case? So I think you
either should set the error variable explicitely here, or simply "return
1" immediately instead of doing the goto.

> +     }
>  
>       if (error) {
>  out:

 Thomas




reply via email to

[Prev in Thread] Current Thread [Next in Thread]