qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v9 00/11] Provide a QOM-based authorization API


From: Daniel P. Berrange
Subject: Re: [Qemu-devel] [PATCH v9 00/11] Provide a QOM-based authorization API
Date: Mon, 15 Aug 2016 14:07:08 +0100
User-agent: Mutt/1.6.2 (2016-07-01)

On Mon, Aug 15, 2016 at 06:04:02AM -0700, address@hidden wrote:
> Hi,
> 
> Your series seems to have some coding style problems. See output below for
> more information:
> 
> Message-id: address@hidden
> Subject: [Qemu-devel] [PATCH v9 00/11] Provide a QOM-based authorization API
> Type: series
> 
> === TEST SCRIPT BEGIN ===
> #!/bin/bash
> 
> BASE=base
> n=1
> total=$(git log --oneline $BASE.. | wc -l)
> failed=0
> 
> commits="$(git log --format=%H --reverse $BASE..)"
> for c in $commits; do
>     echo "Checking PATCH $n/$total: $(git show --no-patch --format=%s $c)..."
>     if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; 
> then
>         failed=1
>         echo
>     fi
>     n=$((n+1))
> done
> 
> exit $failed
> === TEST SCRIPT END ===
> 
> Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
> From https://github.com/patchew-project/qemu
>  * [new tag]         patchew/address@hidden -> patchew/address@hidden
> Switched to a new branch 'test'
> 3a1d870 qmp: add support for mixed typed input visitor
> 01a6fe2 util: add QAuthZPAM object type for authorizing using PAM
> b0380fb acl: delete existing ACL implementation
> 3de7df2 util: add QAuthZSimple object type for a simple access control list
> 6e54576 util: add QAuthZ object as an authorization base class
> a128fba qom: support arbitrary non-scalar properties with -object
> 33a535d qapi: add a QmpInputVisitor that does string conversion
> dcbcfba qapi: rename QmpOutputVisitor to QObjectOutputVisitor
> 2b2fc3a qapi: rename QmpInputVisitor to QObjectInputVisitor
> f2552c3 option: make parse_option_bool/number non-static
> 4f7ac55 qdict: implement a qdict_crumple method for un-flattening a dict
> 
> === OUTPUT BEGIN ===
> Checking PATCH 1/11: qdict: implement a qdict_crumple method for 
> un-flattening a dict...
> Checking PATCH 2/11: option: make parse_option_bool/number non-static...
> Checking PATCH 3/11: qapi: rename QmpInputVisitor to QObjectInputVisitor...
> ERROR: open brace '{' following struct go on the same line
> #572: FILE: qapi/qobject-input-visitor.c:27:
> +typedef struct StackObject
> +{

[snip]

This and all the other errors reported here are all *pre-existing*
problems. It seems this bot does not have git rename detection turned
on so is reporting all these problems in file-renames my patches did.

The bot needs to have something like this added to its $HOME/.gitconfig:

  [diff]
  renamelimit=1000
  renames=True


Regards,
Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|



reply via email to

[Prev in Thread] Current Thread [Next in Thread]