qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 2/3] audio: Rename audio_init() to soundhw_init()


From: Eduardo Habkost
Subject: [Qemu-devel] [PATCH 2/3] audio: Rename audio_init() to soundhw_init()
Date: Tue, 17 Jan 2017 16:46:37 -0200

To make it consistent with the remaining soundhw.c functions and
avoid confusion with the audio_init() function in audio/audio.c,
rename audio_init() to soundhw_init().

Signed-off-by: Eduardo Habkost <address@hidden>
---
 include/hw/audio/audio.h | 2 +-
 hw/audio/soundhw.c       | 2 +-
 vl.c                     | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/hw/audio/audio.h b/include/hw/audio/audio.h
index 259bb2cf96..119f7d78d5 100644
--- a/include/hw/audio/audio.h
+++ b/include/hw/audio/audio.h
@@ -7,7 +7,7 @@ void isa_register_soundhw(const char *name, const char *descr,
 void pci_register_soundhw(const char *name, const char *descr,
                           int (*init_pci)(PCIBus *bus));
 
-void audio_init(void);
+void soundhw_init(void);
 void select_soundhw(const char *optarg);
 
 #endif
diff --git a/hw/audio/soundhw.c b/hw/audio/soundhw.c
index 3411fe1f90..2178a5c8ef 100644
--- a/hw/audio/soundhw.c
+++ b/hw/audio/soundhw.c
@@ -127,7 +127,7 @@ void select_soundhw(const char *optarg)
     }
 }
 
-void audio_init(void)
+void soundhw_init(void)
 {
     struct soundhw *c;
     ISABus *isa_bus =
diff --git a/vl.c b/vl.c
index cb610873bc..a5bf85ebec 100644
--- a/vl.c
+++ b/vl.c
@@ -4546,7 +4546,7 @@ int main(int argc, char **argv, char **envp)
 
     realtime_init();
 
-    audio_init();
+    soundhw_init();
 
     cpu_synchronize_all_post_init();
 
-- 
2.11.0.259.g40922b1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]