qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v6 2/4] hw/acpi-build: Make assignment statement


From: Eduardo Habkost
Subject: Re: [Qemu-devel] [PATCH v6 2/4] hw/acpi-build: Make assignment statement of next_base easy to read
Date: Mon, 9 Oct 2017 23:29:58 -0300
User-agent: Mutt/1.9.0 (2017-09-02)

On Fri, Sep 01, 2017 at 10:10:03AM +0800, Dou Liyang wrote:
> It may be hard to read the assignment statement of "next_base", so
> 
> S/next_base += (1ULL << 32) - pcms->below_4g_mem_size;
>  /next_base = mem_base + mem_len;
> 
> ... for readability.
> 
> No functionality change.
> 
> Signed-off-by: Dou Liyang <address@hidden>

This or the new test case at patch 3/4 seem to have caused build
failures under some circumstances:

https://www.mail-archive.com/address@hidden/msg486368.html

I couldn't reproduce the failure yet, but I'm removing this and
patch 3/4 from the queue until this is investigated.

> ---
>  hw/i386/acpi-build.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/hw/i386/acpi-build.c b/hw/i386/acpi-build.c
> index a0cf3bf..48525a1 100644
> --- a/hw/i386/acpi-build.c
> +++ b/hw/i386/acpi-build.c
> @@ -2411,7 +2411,7 @@ build_srat(GArray *table_data, BIOSLinker *linker, 
> MachineState *machine)
>              }
>              mem_base = 1ULL << 32;
>              mem_len = next_base - pcms->below_4g_mem_size;
> -            next_base += (1ULL << 32) - pcms->below_4g_mem_size;
> +            next_base = mem_base + mem_len;
>          }
>          numamem = acpi_data_push(table_data, sizeof *numamem);
>          build_srat_memory(numamem, mem_base, mem_len, i - 1,
> -- 
> 2.5.5
> 
> 
> 
> 

-- 
Eduardo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]