qemu-s390x
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [qemu-s390x] [PATCH] hw/s390/ccw.c: Don't take address of packed mem


From: Cornelia Huck
Subject: Re: [qemu-s390x] [PATCH] hw/s390/ccw.c: Don't take address of packed members
Date: Thu, 13 Dec 2018 09:21:38 +0100

On Wed, 12 Dec 2018 21:15:29 +0000
Peter Maydell <address@hidden> wrote:

> On Wed, 12 Dec 2018 at 17:34, Cornelia Huck <address@hidden> wrote:
> >
> > On Mon, 10 Dec 2018 14:23:15 +0000
> > Peter Maydell <address@hidden> wrote:
> >  
> > > On Mon, 10 Dec 2018 at 14:13, Cornelia Huck <address@hidden> wrote:  
> > > >
> > > > On Mon, 10 Dec 2018 13:58:03 +0000
> > > > Peter Maydell <address@hidden> wrote:
> > > >  
> > > > > Taking the address of a field in a packed struct is a bad idea, 
> > > > > because
> > > > > it might not be actually aligned enough for that pointer type (and
> > > > > thus cause a crash on dereference on some host architectures). Newer
> > > > > versions of clang warn about this.
> > > > >
> > > > > Avoid the problem by using local copies of the PMCW and SCSW
> > > > > struct fields in copy_schib_from_guest() and copy_schib_to_guest().
> > > > >
> > > > > Signed-off-by: Peter Maydell <address@hidden>
> > > > > ---
> > > > > This seemed like a not totally ugly and reasonably localised fix
> > > > > that satisfies clang. Oddly, this makes the generated object file
> > > > > 15K smaller (421K vs 406K), so it might even be better code...  
> > > >
> > > > Nice :)
> > > >  
> > > > >
> > > > >  hw/s390x/css.c | 20 ++++++++++++++++----
> > > > >  1 file changed, 16 insertions(+), 4 deletions(-)
> > > > >
> > > > > diff --git a/hw/s390x/css.c b/hw/s390x/css.c
> > > > > index 04ec5cc9705..ef07691e36b 100644
> > > > > --- a/hw/s390x/css.c
> > > > > +++ b/hw/s390x/css.c
> > > > > @@ -1290,9 +1290,15 @@ void copy_scsw_to_guest(SCSW *dest, const SCSW 
> > > > > *src)
> > > > >  static void copy_schib_to_guest(SCHIB *dest, const SCHIB *src)
> > > > >  {
> > > > >      int i;
> > > > > +    PMCW srcpmcw, destpmcw;
> > > > > +    SCSW srcscsw, destscsw;  
> > > >
> > > > <bikeshed>
> > > > I would find src_pmcw etc. easier to read. Other opinions?
> > > > </bikeshed>  
> > >
> > > CODING_STYLE's "Naming" section agrees with you...  
> >
> > Do you plan to send a v2, or should I just rename and apply?  
> 
> If you want to rename and apply that would be great; I can
> send a v2 if that's easier for you.
> 
> thanks
> -- PMM

Given that Thomas also wanted a comment added, a v2 would be easier for
me.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]