[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[RP] Re: window numbering bug/race?

From: Mark Eichin
Subject: [RP] Re: window numbering bug/race?
Date: Wed, 23 Nov 2005 14:33:54 -0500

It's been happening reliably under 1.3.0 for a while now - it was only
recently that I realized that the "something odd" was actually a
consistent ordering problem.  That (and the Attempt to release -1
noise) was what got me to try the CVS mainline, and I've only started
it once with that build but it happenned the first time - so it
certainly seems reliable for me, at least in my current config.

On 11/23/05, Joshua Neuheisel <address@hidden> wrote:
> address@hidden wrote:
> > "ratpoison -c windows" shows that I have 12 windows, two of which are
> > numbered "10".  If I select window 9 and go "next", I get one of
> > them; if I select 0 and go "prev", I get the other.  One is an xterm,
> > the other is a dclock; they were all started sequentially using
> > xtoolwait (thus rapidly, but in a well defined order.)
> >
> > First noticed it with 1.3.0-7 under ubuntu; that doesn't mean it
> > wasn't happening under debian, but I hadn't *noticed* it there.  Built
> > from CVS a few days ago, with the latest ChangeLog entry being
> > 2005-11-05, and it still happens the same way.
> >
> > I haven't dug deeper yet, other than to check the mailing list for the
> > last couple of months and not see any mention of it.  I can try
> > turning on PRINT_DEBUG and see what the new-frame calculations do; any
> > other suggestions?
> I've seen this before, but I can't reproduce it.  Does it happen every
> time you start RP?
> Joshua

_Mark_ <address@hidden> <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]