rdiff-backup-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] rdiff "libgdkxft.so" installation dependency error


From: Fraser Keith
Subject: [rdiff-backup-users] rdiff "libgdkxft.so" installation dependency error
Date: Sun, 29 Sep 2002 20:50:28 +0000

Hi All,

I am trying to install the rdiff package on a RedHat linux 7.3 system and I am having a dependency problem I can seem to resolve. Hopefully someone can point me in the direction.

On attempting to install rdiff I get:

 $ sudo rpm -ivh rdiff-backup-0.10.1-1.i386.rpm
 error: failed dependencies:
         librsync >= 0.9.5.1 is needed by rdiff-backup-0.10.1-1
         libgdkxft.so.0   is needed by rdiff-backup-0.10.1-1
         librsync.so.1   is needed by rdiff-backup-0.10.1-1

So, I try to resolve the first dependency:

 $ sudo rpm -ivh librsync-0.9.5.1-2.i386.rpm
 error: failed dependencies:
         libgdkxft.so.0   is needed by librsync-0.9.5.1-2

So, what is libgdkxft.so? I checked google and found that it's an anti-aliasing font library. For a backup tool? That can't be right...

I then tried to get it installed anyway, so I find the package listed on SourceForge at: http://sourceforge.net/project/showfiles.php?group_id=38513

Now, this then fails because:

 $ sudo rpm -ivh gdkxft-1.4-1.i386.rpm
 error: failed dependencies:
         libgcc_s.so.1   is needed by gdkxft-1.4-1

Now, I thought I'd installed the dev environment on this box, but I guess not. Time to install libgcc:

 $ sudo rpm -ivh /mnt/valhalla/disc2/RedHat/RPMS/gcc-2.96-110.i386.rpm
 error: failed dependencies:
         cpp = 2.96-110 is needed by gcc-2.96-110

Here we go again, install cpp this time...:

 $ sudo rpm -ivh /mnt/valhalla/disc2/RedHat/RPMS/cpp-2.96-110.i386.rpm
Preparing... ########################################### [100%] package cpp-2.96-112 (which is newer than cpp-2.96-110) is already installed file /usr/bin/cpp from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/lib/gcc-lib/i386-redhat-linux/2.96/cpp0 from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/lib/gcc-lib/i386-redhat-linux/2.96/tradcpp0 from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/share/info/cpp.info-1.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/share/info/cpp.info-2.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/share/info/cpp.info-3.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/share/info/cpp.info.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112 file /usr/share/man/man1/cpp.1.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-112

At this point I yell at the monitor and go for a beer. Several in fact. Now that I have sobered up, can anyone give me a suggestion on what I can do to resolve this? I've looked all over the place, google www/groups a number of searches and not a thing is listed anywhere.

Thanks in advance,

Fraser.

_________________________________________________________________
Join the worldÂ’s largest e-mail service with MSN Hotmail. http://www.hotmail.com





reply via email to

[Prev in Thread] Current Thread [Next in Thread]