[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] KeyError exception

From: Andrew Ferguson
Subject: Re: [rdiff-backup-users] KeyError exception
Date: Sun, 27 Jan 2008 11:04:38 -0500
User-agent: Thunderbird (Macintosh/20071210)

Austin Clements wrote:
> I don't know why I didn't think of this before...  I reverted your
> patch and tried running the backup again and it worked, suggesting
> that your patch fixes the issue when creating a new backup, but breaks
> something when trying to increment an existing backup.  However, then
> I ran the incremental backup again and it failed with a KeyError, so I
> reinstated your patch and it failed with the same KeyError.  Just to
> check that the backup itself wasn't wedged, I ran the incremental a
> different way that doesn't use both a remote source and a remote
> destination and it worked.  So now I'm just completely bamboozled.
> Quoth myself on Jan 21 at  5:12 pm:
>> Scratch that.  The initial backup task worked, but the next one failed
>> with a very similar error involving rorp's, fast processing, and
>> KeyErrors.  The destination side raised the following exception:
>> *chomp*


Maybe we can solve this by adjusting the threshold at which rdiff-backup
is flushing the pipeline.

The controlling statement would be line 164 in the backup.py I sent you.
It should say:
flush_threshold = Globals.pipeline_max_length - 2

Try changing that to a smaller number, perhaps with:

flush_threshold = int(Globals.pipeline_max_length/2)


flush_threshold = Globals.pipeline_max_length - 20


See if one of those works for you. I know this is voodoo.... :(


Andrew Ferguson - address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]