[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Permission denied errors on files that original

From: chuck odonnell
Subject: Re: [rdiff-backup-users] Permission denied errors on files that originally have no user
Date: Thu, 6 Mar 2008 09:36:29 -0500

On Thu, Mar 06, 2008 at 01:50:23AM +0100, Peter Schuller wrote:
> > 1. the user running rdiff-backup (i run it as root)
> > 2. underlying filesystem (freebsd 7 has some new options for the file
> > system) 3. secure level. i run with the default secure level
> > 4. something specific to rdiff-backup-dev (i am using rdiff-backup stable)
> It's probably 1 and/or 4.
> I am using ZFS, but the reason for failure at the point of reading is pretty 
> expected (since it *does* have u-r and I am running as non-root, and it does 
> not do any chmod magic or similar).

hi peter. i may be misunderstanding the givens, but this does not
sound like a situation that can be fixed within rdiff-backup. if you
are running as a non-root user who does not own the file, you will not
have permission to chmod it in order to read it.

you should be able to verify this on the command line. rdiff-backup is
a filesystem-based backup utility, like tar, and is subject to the
same constraints as the command line (constrast to 'dump' or 'dd' that
bypass the filesystem and only need read permission on the raw

$ cat /usr/local/bin/sudoedit 
cat: /usr/local/bin/sudoedit: Permission denied
$ chmod 4115 /usr/local/bin/sudoedit 
chmod: /usr/local/bin/sudoedit: Operation not permitted

if i am missing something let me know!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]