ring
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ring] updating Ring, can't log in


From: Stepan Salenikovich
Subject: Re: [Ring] updating Ring, can't log in
Date: Wed, 2 Aug 2017 14:53:35 -0400

On Wed, Aug 2, 2017 at 1:11 PM, Anthony Léonard
<address@hidden> wrote:
> Hi,
>
>> I installed the Ring package on Debian quite some time ago in 2016.
>>
>> This week I took the latest package from unstable, compiled it on a
>> system running stretch and installed it.  Version
>> 20170720.2.5bf0a65~dfsg1-1
>>
>> When I start it, I see a window that says "Account migration
>> required"
>
> That's because Ring has changed a lot between 2016 and today,
> especially in October/November of last year. It needs to decipher your
> private key archive to make updates to it.
>
>> I don't remember setting any password but it won't let me proceed
>> without typing a password.
>
> Something is weird as in the old version, a password wasn't mandatory
> so it should have asked you to create one but not entering a
> preexisting. There's probably a true problem here that we should
> investigate.

You should verify with Adrien, but IIRC it was chosen to no longer
support such old versions at all, so migration is not possible if you
have an account old enough to not even have a password. In this case,
the bug is that there is no way to delete this unusable account and
that Ring even tries to migrate it at all.

>
>> Also, I don't have any friends added to that Ring account, it was
>> just a
>> test - I would like to remove that account on the Debian system and
>> make
>> it use the RingID currently working on my Android device.
>
> To delete your account and any other Ring configuration, you can delete
> those folders (with Ring not being running):
>   - ~/.config/ring
>   - ~/.local/share/ring
>   - ~/.local/share/gnome-ring (may not exist)
>   - ~/.cache/ring
>   - ~/.cache/gnome-ring (may not exist)
>
> On the next start, it will behave like a new fresh install.
>
>> On the Android device, I have Ring from F-Droid, version 20170215
>
> This version should be ok. You can download a more recent one on Google
> Play if necessary. The F-Droid version is not as much up-to-date due to
> problems on F-Droid side (but I'm not the most knowledgeable about
> what's happening exactly with them).
>
> Best regards.
>
> Anthony L.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]